kernel: update linux 3.3 to 3.3.7
authorGabor Juhos <juhosg@openwrt.org>
Wed, 23 May 2012 21:05:32 +0000 (21:05 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 23 May 2012 21:05:32 +0000 (21:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31848 3c298f89-4303-0410-b956-a3cf2f4a3e73

34 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/adm8668/Makefile
target/linux/amazon/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/gemini/Makefile
target/linux/generic/patches-3.3/046-fq_codel-qdisc-backlog.patch
target/linux/generic/patches-3.3/252-mv_cesa_depends.patch
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/kirkwood/Makefile
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/omap4/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/pxa/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/realview/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index 145ee2b..9ced644 100644 (file)
@@ -38,8 +38,8 @@ endif
 ifeq ($(LINUX_VERSION),3.2.16)
   LINUX_KERNEL_MD5SUM:=246e6bd28ea44c90ec66c7f8b56e4803
 endif
-ifeq ($(LINUX_VERSION),3.3.6)
-  LINUX_KERNEL_MD5SUM:=35f7f41aed080ca03995e06112182677
+ifeq ($(LINUX_VERSION),3.3.7)
+  LINUX_KERNEL_MD5SUM:=6709647a7576c9e21b082f4d3d7a94cf
 endif
 
 # disable the md5sum check for unknown kernel versions
index e534dcf..e4bd0dd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index b7d1d5f..6761544 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Infineon WildPass ADM8668
 FEATURES:=squashfs
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
index dc0796b..f503629 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 33ffef0..eb2024d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 49da9a3..227ae61 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 05bafcd..c18db95 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 SUBTARGETS:=9g20 9260 9263
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index 6080936..12fe791 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 26ee6e4..4fc7708 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 3cd5d1d..076d572 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 9072e9b..2fdd569 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index a3c2d93..53dd8dc 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 0a20883..8b84d8d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 5fc75a0..e8154b5 100644 (file)
@@ -20,11 +20,9 @@ Cc: Van Jacobson <van@pollere.net>
  net/sched/sch_fq_codel.c |    5 +++--
  3 files changed, 12 insertions(+), 12 deletions(-)
 
-diff --git a/include/net/codel.h b/include/net/codel.h
-index 7546517..550debf 100644
 --- a/include/net/codel.h
 +++ b/include/net/codel.h
-@@ -205,7 +205,7 @@ static codel_time_t codel_control_law(codel_time_t t,
+@@ -205,7 +205,7 @@ static codel_time_t codel_control_law(co
  
  
  static bool codel_should_drop(const struct sk_buff *skb,
@@ -33,7 +31,7 @@ index 7546517..550debf 100644
                              struct codel_vars *vars,
                              struct codel_params *params,
                              struct codel_stats *stats,
-@@ -219,13 +219,13 @@ static bool codel_should_drop(const struct sk_buff *skb,
+@@ -219,13 +219,13 @@ static bool codel_should_drop(const stru
        }
  
        vars->ldelay = now - codel_get_enqueue_time(skb);
@@ -49,7 +47,7 @@ index 7546517..550debf 100644
                /* went below - stay below for at least interval */
                vars->first_above_time = 0;
                return false;
-@@ -249,8 +249,7 @@ static struct sk_buff *codel_dequeue(struct Qdisc *sch,
+@@ -249,8 +249,7 @@ static struct sk_buff *codel_dequeue(str
                                     struct codel_params *params,
                                     struct codel_vars *vars,
                                     struct codel_stats *stats,
@@ -59,7 +57,7 @@ index 7546517..550debf 100644
  {
        struct sk_buff *skb = dequeue_func(vars, sch);
        codel_time_t now;
-@@ -261,7 +260,7 @@ static struct sk_buff *codel_dequeue(struct Qdisc *sch,
+@@ -261,7 +260,7 @@ static struct sk_buff *codel_dequeue(str
                return skb;
        }
        now = codel_get_time();
@@ -68,7 +66,7 @@ index 7546517..550debf 100644
        if (vars->dropping) {
                if (!drop) {
                        /* sojourn time below target - leave dropping state */
-@@ -292,7 +291,7 @@ static struct sk_buff *codel_dequeue(struct Qdisc *sch,
+@@ -292,7 +291,7 @@ static struct sk_buff *codel_dequeue(str
                                qdisc_drop(skb, sch);
                                stats->drop_count++;
                                skb = dequeue_func(vars, sch);
@@ -77,7 +75,7 @@ index 7546517..550debf 100644
                                                       vars, params, stats, now)) {
                                        /* leave dropping state */
                                        vars->dropping = false;
-@@ -313,7 +312,7 @@ static struct sk_buff *codel_dequeue(struct Qdisc *sch,
+@@ -313,7 +312,7 @@ static struct sk_buff *codel_dequeue(str
                        stats->drop_count++;
  
                        skb = dequeue_func(vars, sch);
@@ -86,11 +84,9 @@ index 7546517..550debf 100644
                                                 stats, now);
                }
                vars->dropping = true;
-diff --git a/net/sched/sch_codel.c b/net/sched/sch_codel.c
-index 213ef60..2f9ab17 100644
 --- a/net/sched/sch_codel.c
 +++ b/net/sched/sch_codel.c
-@@ -77,8 +77,8 @@ static struct sk_buff *codel_qdisc_dequeue(struct Qdisc *sch)
+@@ -77,8 +77,8 @@ static struct sk_buff *codel_qdisc_deque
        struct codel_sched_data *q = qdisc_priv(sch);
        struct sk_buff *skb;
  
@@ -101,11 +97,9 @@ index 213ef60..2f9ab17 100644
        /* We cant call qdisc_tree_decrease_qlen() if our qlen is 0,
         * or HTB crashes. Defer it for next round.
         */
-diff --git a/net/sched/sch_fq_codel.c b/net/sched/sch_fq_codel.c
-index 337ff20..9fc1c62 100644
 --- a/net/sched/sch_fq_codel.c
 +++ b/net/sched/sch_fq_codel.c
-@@ -217,13 +217,14 @@ static int fq_codel_enqueue(struct sk_buff *skb, struct Qdisc *sch)
+@@ -217,13 +217,14 @@ static int fq_codel_enqueue(struct sk_bu
   */
  static struct sk_buff *dequeue(struct codel_vars *vars, struct Qdisc *sch)
  {
@@ -130,4 +124,3 @@ index 337ff20..9fc1c62 100644
  
        flow->dropped += q->cstats.drop_count - prev_drop_count;
        flow->dropped += q->cstats.ecn_mark - prev_ecn_mark;
-
index b43d29c..5370145 100644 (file)
@@ -6,5 +6,5 @@
        select CRYPTO_AES
 +      select CRYPTO_HASH2
        select CRYPTO_BLKCIPHER2
+       select CRYPTO_HASH
        help
-         This driver allows you to utilize the Cryptographic Engines and
index 6c2da5d..e52720a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index c3be9cb..8a2dc48 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 1057100..da44def 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell Kirkwood
 FEATURES:=targz usb jffs2
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index c4a84b3..4c0ada3 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
 DEFAULT_SUBTARGET:=danube
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
index 7cfacb9..f30286c 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index ba90745..ce49cb7 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 711bd98..3542bf8 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 270ac22..3bfbf6c 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index bc89c08..d434736 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=omap4
 BOARDNAME:=TI OMAP4
 FEATURES:=usb targz audio display
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
index 8008c09..995fcf4 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk dns323
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index ac02493..3b6c7b7 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index cf6cf59..4c16b61 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=squashfs broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 5616168..be42e51 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index fd07161..02a819f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 8484759..4a7653e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb pcmcia broken
 CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index ab7d8d0..e565593 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 7ebf257..2c30106 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk broken
 CFLAGS:=-Os -pipe -march=sb1 -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index ef8af39..d4d777b 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk
 
index aaa9e02..0e56fbb 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan
 
-LINUX_VERSION:=3.3.6
+LINUX_VERSION:=3.3.7
 
 include $(INCLUDE_DIR)/target.mk