ar71xx: add support for TP-Link TL-MR3040
authorGabor Juhos <juhosg@openwrt.org>
Wed, 23 May 2012 21:05:24 +0000 (21:05 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 23 May 2012 21:05:24 +0000 (21:05 +0000)
Support for TP-Link TL-MR3040. Power LED not working - always on red, after
start should be green.

Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31845 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 35eca7c..ddeee3e 100755 (executable)
@@ -112,6 +112,9 @@ tplink_board_detect() {
        "302000"*)
                model="TP-Link TL-MR3020"
                ;;
+       "304000"*)
+               model="TP-Link TL-MR3040"
+               ;;
        "322000"*)
                model="TP-Link TL-MR3220"
                ;;
index 5c18c44..9a0d2ff 100644 (file)
@@ -27,6 +27,17 @@ endef
 $(eval $(call Profile,TLMR3020))
 
 
+define Profile/TLMR3040
+       NAME:=TP-LINK TL-MR3040
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR3040/Description
+       Package set optimized for the TP-LINK TL-MR3040.
+endef
+$(eval $(call Profile,TLMR3040))
+
+
 define Profile/TLMR3220
        NAME:=TP-LINK TL-MR3220
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
index f99c01a..2f6a161 100644 (file)
@@ -877,6 +877,11 @@ define Image/Build/Profile/TLMR3020
        $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK-LZMA,tl-mr3020-v1,$(tlmr3020_cmdline),0x30200001,1,4Mlzma)
 endef
 
+tlmr3040_cmdline=board=TL-MR11U console=ttyATH0,115200
+define Image/Build/Profile/TLMR3040
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-mr3040-v1,$(tlmr3040_cmdline),0x30400001,1,4Mlzma)
+endef
+
 tlmr3220_cmdline=board=TL-MR3220 console=ttyS0,115200
 define Image/Build/Profile/TLMR3220
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-mr3220-v1,$(tlmr3220_cmdline),0x32200001,1,4M)
@@ -1081,6 +1086,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TEW673GRU,$(1))
        $(call Image/Build/Profile/TLMR11U,$(1))
        $(call Image/Build/Profile/TLMR3020,$(1))
+       $(call Image/Build/Profile/TLMR3040,$(1))
        $(call Image/Build/Profile/TLMR3220,$(1))
        $(call Image/Build/Profile/TLMR3420,$(1))
        $(call Image/Build/Profile/TLWA701,$(1))