CC: dropbear: Make utmp and putuline support configurable via seperate config options
authorHans Dedecker <dedeckeh@gmail.com>
Thu, 31 Aug 2017 06:50:09 +0000 (08:50 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 31 Aug 2017 06:50:09 +0000 (08:50 +0200)
Utmp support tracks who is currenlty logged in by logging info to the file /var/run/utmp (supported by busybox)
Putuline support will use the utmp structure to write to the utmp file

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/services/dropbear/Config.in
package/network/services/dropbear/Makefile

index 3316c84..7c2edd7 100644 (file)
@@ -32,4 +32,19 @@ config DROPBEAR_ECC
 
                Increases binary size by about 23 kB (MIPS).
 
+config DROPBEAR_UTMP
+       bool "Utmp support"
+       default n
+       depends on BUSYBOX_CONFIG_FEATURE_UTMP
+       help
+               This enables dropbear utmp support, the file /var/run/utmp is used to
+               track who is currently logged in.
+
+config DROPBEAR_PUTUTLINE
+       bool "Pututline support"
+       default n
+       depends on DROPBEAR_UTMP
+       help
+               Dropbear will use pututline() to write the utmp structure into the utmp file.
+
 endmenu
index f48c2b5..8d4e7bc 100644 (file)
@@ -68,12 +68,11 @@ CONFIGURE_ARGS += \
        --enable-syslog \
        $(if $(CONFIG_SHADOW_PASSWORDS),,--disable-shadow) \
        --disable-lastlog \
-       --disable-utmp \
-       --disable-utmpx \
+       $(if $(CONFIG_DROPBEAR_UTMP),,--disable-utmp) \
        --disable-wtmp \
        --disable-wtmpx \
        --disable-loginfunc \
-       --disable-pututline \
+       $(if $(CONFIG_DROPBEAR_PUTUTLINE),,--disable-pututline) \
        --disable-pututxline \
        --disable-zlib \
        --enable-bundled-libtom