kernel: fix kmod-k10temp target dependencies
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 29 May 2015 12:03:00 +0000 (12:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 29 May 2015 12:03:00 +0000 (12:03 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45825 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk

index 61e71ea..c649847 100644 (file)
@@ -304,7 +304,7 @@ define KernelPackage/hwmon-k10temp
   KCONFIG:=CONFIG_SENSORS_K10TEMP
   FILES:=$(LINUX_DIR)/drivers/hwmon/k10temp.ko
   AUTOLOAD:=$(call AutoLoad,60,k10temp)
-  $(call AddDepends/hwmon,@PCI_SUPPORT @(x86||x86_64))
+  $(call AddDepends/hwmon,@PCI_SUPPORT @TARGET_x86)
 endef
 
 define KernelPackage/hwmon-k10temp/description