ar71xx: Add TP-Link TL-WR740N v6 support to 15.05.1
authorJohn Crispin <blogic@openwrt.org>
Mon, 25 Apr 2016 20:08:44 +0000 (20:08 +0000)
committerJohn Crispin <blogic@openwrt.org>
Mon, 25 Apr 2016 20:08:44 +0000 (20:08 +0000)
This patch adds support for the TP-Link TL-WR740N v6 to OpenWrt Chaos Calmer. Hardware wise, it's very similar to the TL-WR841N v10. See the forum thread [1]. Credit goes to the user 'traveler' who did the legwork and tested builds.

Also thanks to Matthias Schiffer for clarifying the DEVICE_PROFILE settings.

Signed-off by: Stijn Segers <francesco.borromini@inventati.org>

[1]: https://forum.openwrt.org/viewtopic.php?pid=318704

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49225 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 1a399ab..cd77373 100644 (file)
@@ -509,6 +509,13 @@ define Device/tl-wr740n-v5
     CONSOLE := ttyATH0,115200
 endef
 
+define Device/tl-wr740n-v6
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR841N-v9
+    DEVICE_PROFILE := TLWR740
+    TPLINK_HWID := 0x07400006
+endef
+
 define Device/tl-wr741nd-v1
     $(Device/tplink-4m)
     BOARDNAME := TL-WR741ND
@@ -546,7 +553,7 @@ define Device/tl-wr743nd-v2
     TPLINK_HWID := 0x07430002
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr740n-v6 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v2
 
 define Device/tl-wr841-v8
     $(Device/tplink-4mlzma)