CC: ramips: Added WIZnet WizFi630A Platfrom based on Ralink RT5350
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Oct 2015 14:16:40 +0000 (14:16 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Oct 2015 14:16:40 +0000 (14:16 +0000)
This patch is to add the WIZnet WizFi630A board as a new platform. The board is in mini pci express form factor.

Signed-off-by: Tobias Welz <tw@wiznet.eu>
This is a backport of patch r46921

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47072 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WIZFI630A.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/wiznet.mk [new file with mode: 0644]

index bc1fc01..6affe9f 100755 (executable)
@@ -156,7 +156,12 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
                ucidef_add_switch_vlan "switch0" "2" "5 6t"
                ;;
-
+       wizfi630a)
+               ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+               ucidef_add_switch "switch0" "1" "1"
+               ucidef_add_switch_vlan "switch0" "1" "1 2 6t"
+               ucidef_add_switch_vlan "switch0" "2" "0 6t"
+               ;;
        awm002-evb | \
        awm003-evb | \
        argus-atp52b | \
@@ -363,6 +368,10 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_binary factory 4)
                lan_mac=$wan_mac
                ;;
+       wizfi630a)
+               lan_mac=$(mtd_get_mac_binary factory 4)
+               wan_mac=$(mtd_get_mac_binary factory 40)
+               ;;
        wsr-1166)
                local index="$(find_mtd_index "board_data")"
                wan_mac="$(grep -m1 mac= "/dev/mtd${index}" | cut -d= -f2)"
index e695778..5fc5137 100644 (file)
@@ -175,6 +175,9 @@ get_status_led() {
        whr-g300n)
                status_led="whr-g300n:green:router"
                ;;
+       wizfi630a)
+               status_led="wizfi630a::run"
+               ;;
        wmr300)
                status_led="buffalo:green:status"
                ;;
index cedd62b..39d74d7 100755 (executable)
@@ -103,6 +103,7 @@ platform_check_image() {
        whr-300hp2 |\
        whr-600d |\
        whr-1166d |\
+       wizfi630a |\
        wsr-600 |\
        wl-330n | \
        wl-330n3g | \
diff --git a/target/linux/ramips/dts/WIZFI630A.dts b/target/linux/ramips/dts/WIZFI630A.dts
new file mode 100644 (file)
index 0000000..f2818ce
--- /dev/null
@@ -0,0 +1,180 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "wizfi630a", "ralink,rt5350-soc";
+       model = "WIZnet WizFi630A";
+
+       chosen {
+               bootargs = "console=ttyS1,115200";
+       };
+
+       palmbus@10000000 {
+               gpio1: gpio@660 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q128";
+                               reg = <0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "uboot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+
+               uart@500 {
+                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
+                       reg = <0x500 0x100>;
+                       resets = <&rstctrl 12>;
+                       reset-names = "uart";
+                       interrupt-parent = <&intc>;
+                       interrupts = <5>;
+                       reg-shift = <2>;
+                       status = "okay";
+               };
+
+               uartlite@c00 {
+                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
+                       reg = <0xc00 0x100>;
+                       resets = <&rstctrl 19>;
+                       reset-names = "uartl";
+                       interrupt-parent = <&intc>;
+                       interrupts = <12>;
+                       reg-shift = <2>;
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&uartlite_pins>;
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag" ;
+                               ralink,function = "gpio";
+                       };
+               };
+
+               uartf_gpio_pins: uartf_gpio {
+                       uartf_gpio {
+                               ralink,group = "uartf";
+                               ralink,function = "uartf";
+                       };
+               };
+
+               uartlite_pins: uartlite {
+                       uart {
+                               ralink,group = "uartlite";
+                               ralink,function = "uartlite";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x17>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               run {
+                       label = "wizfi630a::run";
+                       gpios = <&gpio0 1 1>;
+               };
+
+               wps {
+                       label = "wizfi630a::wps";
+                       gpios = <&gpio0 20 1>;
+               };
+
+               uart1 {
+                       label = "wizfi630a::uart1";
+                       gpios = <&gpio0 18 1>;
+               };
+
+               uart2 {
+                       label = "wizfi630a::uart2";
+                       gpios = <&gpio0 21 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 17 1>;
+                       linux,code = <0x198>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x211>;
+               };
+               
+               scm1 {
+                       label = "SCM1";
+                       gpios = <&gpio0 19 1>;
+                       linux,code = <0x100>;
+               };
+
+               scm2 {
+                       label = "SCM2";
+                       gpios = <&gpio0 2 1>;
+                       linux,code = <0x101>;
+               };
+       };
+};
index 776920b..3bfbcd0 100644 (file)
@@ -627,6 +627,8 @@ endef
 BuildFirmware/WHRG300N/initramfs=$(call BuildFirmware/OF/initramfs,$(1),whr-g300n,WHR-G300N)
 Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))
 
+Image/Build/Profile/WIZFI630A=$(call BuildFirmware/Default16M/$(1),$(1),wizfi630a,WIZFI630A)
+
 Image/Build/Profile/WIZARD8800=$(call BuildFirmware/Default8M/$(1),$(1),wizard-8800,WIZARD8800,Linux Kernel Image)
 
 Image/Build/Profile/WL_330N=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n,WL_330N)
@@ -761,6 +763,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WIZARD8800,$(1))
+       $(call Image/Build/Profile/WIZFI630A,$(1))
        $(call Image/Build/Profile/WL_330N,$(1))
        $(call Image/Build/Profile/WL_330N3G,$(1))
        $(call Image/Build/Profile/WL341V3,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/wiznet.mk b/target/linux/ramips/rt305x/profiles/wiznet.mk
new file mode 100644 (file)
index 0000000..83f2af0
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WIZFI630A
+       NAME:=WIZnet WizFi630A
+       PACKAGES:=\
+               kmod-usb2
+endef
+
+define Profile/WIZFI630A/Description
+       Package set for WIZnet WizFi630A board
+endef
+$(eval $(call Profile,WIZFI630A))