kernel/gpio_keys: load module on pre-init
authorJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:14:51 +0000 (08:14 +0000)
committerJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:14:51 +0000 (08:14 +0000)
fix rescue mode on wdr4900

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Backport of r48793

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48851 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/input.mk

index 86ff33c..eed9aa2 100644 (file)
@@ -75,7 +75,7 @@ define KernelPackage/input-gpio-keys
        CONFIG_KEYBOARD_GPIO \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
-  AUTOLOAD:=$(call AutoProbe,gpio_keys)
+  AUTOLOAD:=$(call AutoProbe,gpio_keys,1)
 endef
 
 define KernelPackage/input-gpio-keys/description