ar71xx: add support for TP-LINK TL-WR941ND v6 (international version)
authorJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:15:02 +0000 (08:15 +0000)
committerJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:15:02 +0000 (08:15 +0000)
The international version is completely different from the already
supported Chinese version. The WLAN of the QCA956x SoC used by this router
has been fixed in r46948.

This patch looks like it changes a lot in
700-MIPS-ath79-openwrt-machines.patch; that is not the case. Unfortunately,
quilt decided to completely reorganize the Kconfig patch even though only
a single section has been added.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Backport of r47420

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48860 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/preinit/05_set_preinit_iface_ar71xx
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-3.18
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr941nd-v6.c [new file with mode: 0644]
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch

index 89fe53c..3e80c32 100644 (file)
@@ -279,7 +279,8 @@ get_status_led() {
        tl-wdr4300 | \
        tl-wr703n | \
        tl-wr710n | \
-       tl-wr720n-v3)
+       tl-wr720n-v3 | \
+       tl-wr941nd-v6)
                status_led="tp-link:blue:system"
                ;;
        tl-wr841n-v9)
index 5241db2..11b3fa0 100644 (file)
@@ -460,6 +460,15 @@ tl-wr941nd-v5)
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
        ;;
 
+tl-wr941nd-v6)
+       ucidef_set_led_netdev "wan" "WAN" "tp-link:blue:wan" "eth0"
+       ucidef_set_led_switch "lan1" "LAN1" "tp-link:blue:lan1" "switch0" "0x10"
+       ucidef_set_led_switch "lan2" "LAN2" "tp-link:blue:lan2" "switch0" "0x08"
+       ucidef_set_led_switch "lan3" "LAN3" "tp-link:blue:lan3" "switch0" "0x04"
+       ucidef_set_led_switch "lan4" "LAN4" "tp-link:blue:lan4" "switch0" "0x02"
+       ucidef_set_led_wlan "wlan" "WLAN" "tp-link:blue:wlan" "phy0tpt"
+       ;;
+
 tl-wa830re-v2)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
index 8143d2d..5a74461 100755 (executable)
@@ -226,6 +226,7 @@ tl-mr3420-v2 |\
 tl-wr841n-v8 |\
 tl-wr842n-v2 |\
 tl-wr941nd-v5 |\
+tl-wr941nd-v6 |\
 wnr2000-v3 |\
 wnr2000-v4 |\
 wnr2200 |\
index f1f5561..d0abf42 100755 (executable)
@@ -800,6 +800,9 @@ ar71xx_board_detect() {
        *"TL-WR941N/ND v5")
                name="tl-wr941nd-v5"
                ;;
+       *"TL-WR941N/ND v6")
+               name="tl-wr941nd-v6"
+               ;;
        *"TL-WR703N v1")
                name="tl-wr703n"
                ;;
index f11ea8c..fd337e1 100644 (file)
@@ -35,6 +35,7 @@ set_preinit_iface() {
        tl-wr720n-v3 |\
        tl-wr841n-v8 |\
        tl-wr842n-v2 |\
+       tl-wr941nd-v6 |\
        wnr2000-v3 |\
        wnr2200 |\
        wnr612-v2 |\
index 8dea48f..2fc1d10 100755 (executable)
@@ -354,6 +354,7 @@ platform_check_image() {
        tl-wr842n-v2 | \
        tl-wr941nd | \
        tl-wr941nd-v5 | \
+       tl-wr941nd-v6 | \
        tl-wr1041n-v2 | \
        tl-wr1043nd | \
        tl-wr1043nd-v2 | \
index e9b3c7c..84b5844 100644 (file)
@@ -132,6 +132,7 @@ CONFIG_ATH79_MACH_TL_WR841N_V1=y
 CONFIG_ATH79_MACH_TL_WR841N_V8=y
 CONFIG_ATH79_MACH_TL_WR841N_V9=y
 CONFIG_ATH79_MACH_TL_WR941ND=y
+CONFIG_ATH79_MACH_TL_WR941ND_V6=y
 CONFIG_ATH79_MACH_TUBE2H=y
 CONFIG_ATH79_MACH_UBNT=y
 CONFIG_ATH79_MACH_UBNT_XM=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr941nd-v6.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr941nd-v6.c
new file mode 100644 (file)
index 0000000..8c788e2
--- /dev/null
@@ -0,0 +1,149 @@
+/*
+ *  TP-LINK TL-WR941N/ND v6 board support
+ *
+ *  Copyright (C) 2015 Matthias Schiffer <mschiffer@universe-factory.net>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+
+#define TL_WR941ND_V6_GPIO_LED_QSS             3
+#define TL_WR941ND_V6_GPIO_LED_WAN             14
+#define TL_WR941ND_V6_GPIO_LED_WAN_RED         15
+#define TL_WR941ND_V6_GPIO_LED_LAN1            7
+#define TL_WR941ND_V6_GPIO_LED_LAN2            6
+#define TL_WR941ND_V6_GPIO_LED_LAN3            5
+#define TL_WR941ND_V6_GPIO_LED_LAN4            4
+#define TL_WR941ND_V6_GPIO_LED_WLAN            8
+#define TL_WR941ND_V6_GPIO_LED_SYSTEM          18
+
+#define TL_WR941ND_V6_GPIO_BTN_RESET           1
+#define TL_WR941ND_V6_GPIO_BTN_RFKILL          2
+
+#define TL_WR941ND_V6_KEYS_POLL_INTERVAL       20
+#define TL_WR941ND_V6_KEYS_DEBOUNCE_INTERVAL   (3 * TL_WR941ND_V6_KEYS_POLL_INTERVAL)
+
+
+static struct gpio_led tl_wr941nd_v6_leds_gpio[] __initdata = {
+       {
+               .name           = "tp-link:blue:qss",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_QSS,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:blue:wan",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_WAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:red:wan",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_WAN_RED,
+               .active_low     = 0,
+       },
+       {
+               .name           = "tp-link:blue:lan1",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_LAN1,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:blue:lan2",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_LAN2,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:blue:lan3",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_LAN3,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:blue:lan4",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_LAN4,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:blue:wlan",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:blue:system",
+               .gpio           = TL_WR941ND_V6_GPIO_LED_SYSTEM,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button tl_wr941nd_v6_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TL_WR941ND_V6_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WR941ND_V6_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "RFKILL button",
+               .type           = EV_KEY,
+               .code           = KEY_RFKILL,
+               .debounce_interval = TL_WR941ND_V6_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WR941ND_V6_GPIO_BTN_RFKILL,
+               .active_low     = 1,
+       }
+};
+
+
+static const char *tl_wr941n_v6_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct flash_platform_data tl_wr941n_v6_flash_data = {
+       .part_probes    = tl_wr941n_v6_part_probes,
+};
+
+
+static void __init tl_wr941nd_v6_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       ath79_register_m25p80(&tl_wr941n_v6_flash_data);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(tl_wr941nd_v6_leds_gpio),
+                                tl_wr941nd_v6_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, TL_WR941ND_V6_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(tl_wr941nd_v6_gpio_keys),
+                                       tl_wr941nd_v6_gpio_keys);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
+
+       ath79_switch_data.phy4_mii_en = 1;
+
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(ee, mac);
+
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WR941ND_V6, "TL-WR941ND-v6", "TP-LINK TL-WR941N/ND v6",
+            tl_wr941nd_v6_setup);
index 24c60f5..8f01a44 100644 (file)
@@ -598,6 +598,13 @@ define Device/tl-wr941nd-v5
     TPLINK_HWID := 0x09410005
 endef
 
+define Device/tl-wr941nd-v6
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR941ND-v6
+    DEVICE_PROFILE := TLWR941
+    TPLINK_HWID := 0x09410006
+endef
+
 # Chinese version (unlike European) is similar to the TL-WDR3500
 define Device/tl-wr941nd-v6-cn
     $(Device/tplink-4mlzma)
@@ -605,7 +612,7 @@ define Device/tl-wr941nd-v6-cn
     DEVICE_PROFILE := TLWR941
     TPLINK_HWID := 0x09410006
 endef
-TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6-cn
+TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6 tl-wr941nd-v6-cn
 
 define Device/tl-wr1041n-v2
     $(Device/tplink-4mlzma)
index 2fa041b..185cb9c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,197 @@
+@@ -16,22 +16,198 @@
  
  enum ath79_mach_type {
        ATH79_MACH_GENERIC = 0,
 +      ATH79_MACH_TL_WR842N_V2,        /* TP-LINK TL-WR842N/ND v2 */
 +      ATH79_MACH_TL_WR941ND,          /* TP-LINK TL-WR941ND */
 +      ATH79_MACH_TL_WR941ND_V5,       /* TP-LINK TL-WR941ND v5 */
++      ATH79_MACH_TL_WR941ND_V6,       /* TP-LINK TL-WR941ND v6 */
 +      ATH79_MACH_TUBE2H,              /* Alfa Network Tube2H */
 +      ATH79_MACH_UBNT_AIRGW,          /* Ubiquiti AirGateway */
        ATH79_MACH_UBNT_AIRROUTER,      /* Ubiquiti AirRouter */
  config ATH79_MACH_AP121
        bool "Atheros AP121 reference board"
        select SOC_AR933X
-@@ -11,62 +75,1041 @@ config ATH79_MACH_AP121
+@@ -11,62 +75,1050 @@ config ATH79_MACH_AP121
        select ATH79_DEV_M25P80
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
 +      select ATH79_DEV_M25P80
 +      select ATH79_DEV_WMAC
 +
++config ATH79_MACH_TL_WR941ND_V6
++      bool "TP-LINK TL-WR941ND v6 support"
++      select SOC_QCA956X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_WMAC
++
 +config ATH79_MACH_TL_WR1041N_V2
 +      bool "TP-LINK TL-WR1041N v2 support"
 +      select SOC_AR934X
  endif
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,126 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
+@@ -38,9 +38,127 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
  #
  # Machines
  #
 +obj-$(CONFIG_ATH79_MACH_TL_WR841N_V8) += mach-tl-wr841n-v8.o
 +obj-$(CONFIG_ATH79_MACH_TL_WR841N_V9) += mach-tl-wr841n-v9.o
 +obj-$(CONFIG_ATH79_MACH_TL_WR941ND)   += mach-tl-wr941nd.o
++obj-$(CONFIG_ATH79_MACH_TL_WR941ND_V6)        += mach-tl-wr941nd-v6.o
 +obj-$(CONFIG_ATH79_MACH_TL_WR1041N_V2)        += mach-tl-wr1041n-v2.o
 +obj-$(CONFIG_ATH79_MACH_TL_WR1043ND)  += mach-tl-wr1043nd.o
 +obj-$(CONFIG_ATH79_MACH_TL_WR1043ND_V2)       += mach-tl-wr1043nd-v2.o