kernel: upgrade to 3.18.75
authorZoltan HERPAI <wigyori@uid0.hu>
Thu, 12 Oct 2017 12:13:56 +0000 (14:13 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 12 Oct 2017 12:13:56 +0000 (14:13 +0200)
Runtime-tested on ar71xx.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
include/kernel-version.mk
target/linux/generic/patches-3.18/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-3.18/721-phy_packets.patch
target/linux/lantiq/patches-3.18/0026-NET-multi-phy-support.patch
target/linux/ramips/patches-3.18/0033-NET-multi-phy-support.patch
target/linux/sunxi/patches-3.18/200-mmc-add-sdio-function-subnode.patch

index 107246a..22902c8 100644 (file)
@@ -2,9 +2,9 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .71
+LINUX_VERSION-3.18 = .75
 
-LINUX_KERNEL_MD5SUM-3.18.71 = 98875fe779041e89c37e51b0208011ea
+LINUX_KERNEL_MD5SUM-3.18.75 = 7e49dc4c2e7abc4398172c04c431dbce
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 6b02b3c..6e90149 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4006,6 +4006,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4009,6 +4009,9 @@ static enum gro_result dev_gro_receive(s
        enum gro_result ret;
        int grow;
  
@@ -27,7 +27,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!(skb->dev->features & NETIF_F_GRO))
                goto normal;
  
-@@ -5077,6 +5080,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -5080,6 +5083,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *private)
-@@ -5137,6 +5182,7 @@ static int __netdev_upper_dev_link(struc
+@@ -5140,6 +5185,7 @@ static int __netdev_upper_dev_link(struc
                        goto rollback_lower_mesh;
        }
  
@@ -84,7 +84,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        call_netdevice_notifiers(NETDEV_CHANGEUPPER, dev);
        return 0;
  
-@@ -5254,6 +5300,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -5257,6 +5303,7 @@ void netdev_upper_dev_unlink(struct net_
        list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
                __netdev_adjacent_dev_unlink(dev, i->dev, i->ref_nr);
  
@@ -92,7 +92,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        call_netdevice_notifiers(NETDEV_CHANGEUPPER, dev);
  }
  EXPORT_SYMBOL(netdev_upper_dev_unlink);
-@@ -5773,6 +5820,7 @@ int dev_set_mac_address(struct net_devic
+@@ -5776,6 +5823,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index 7235ab3..5d6a878 100644 (file)
@@ -86,7 +86,7 @@
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -2626,10 +2626,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -2629,10 +2629,20 @@ static int xmit_one(struct sk_buff *skb,
        if (!list_empty(&ptype_all))
                dev_queue_xmit_nit(skb, dev);
  
index 27d3bce..5943602 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/net/phy/phy.c
 +++ b/drivers/net/phy/phy.c
-@@ -841,7 +841,8 @@ void phy_state_machine(struct work_struc
+@@ -838,7 +838,8 @@ void phy_state_machine(struct work_struc
                /* If the link is down, give up on negotiation for now */
                if (!phydev->link) {
                        phydev->state = PHY_NOLINK;
@@ -21,7 +21,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                        phydev->adjust_link(phydev->attached_dev);
                        break;
                }
-@@ -914,7 +915,8 @@ void phy_state_machine(struct work_struc
+@@ -911,7 +912,8 @@ void phy_state_machine(struct work_struc
                        netif_carrier_on(phydev->attached_dev);
                } else {
                        phydev->state = PHY_NOLINK;
@@ -31,7 +31,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                }
  
                phydev->adjust_link(phydev->attached_dev);
-@@ -926,7 +928,8 @@ void phy_state_machine(struct work_struc
+@@ -923,7 +925,8 @@ void phy_state_machine(struct work_struc
        case PHY_HALTED:
                if (phydev->link) {
                        phydev->link = 0;
index 1baf40d..f6d2456 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/net/phy/phy.c
 +++ b/drivers/net/phy/phy.c
-@@ -841,7 +841,8 @@ void phy_state_machine(struct work_struc
+@@ -838,7 +838,8 @@ void phy_state_machine(struct work_struc
                /* If the link is down, give up on negotiation for now */
                if (!phydev->link) {
                        phydev->state = PHY_NOLINK;
@@ -21,7 +21,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                        phydev->adjust_link(phydev->attached_dev);
                        break;
                }
-@@ -914,7 +915,8 @@ void phy_state_machine(struct work_struc
+@@ -911,7 +912,8 @@ void phy_state_machine(struct work_struc
                        netif_carrier_on(phydev->attached_dev);
                } else {
                        phydev->state = PHY_NOLINK;
@@ -31,7 +31,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                }
  
                phydev->adjust_link(phydev->attached_dev);
-@@ -926,7 +928,8 @@ void phy_state_machine(struct work_struc
+@@ -923,7 +925,8 @@ void phy_state_machine(struct work_struc
        case PHY_HALTED:
                if (phydev->link) {
                        phydev->link = 0;
index dcbb3a4..f8a307e 100644 (file)
@@ -108,7 +108,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
  #include "sdio_cis.h"
  #include "sdio_bus.h"
  
-@@ -303,6 +305,13 @@ static void sdio_acpi_set_handle(struct
+@@ -313,6 +315,13 @@ static void sdio_acpi_set_handle(struct
  static inline void sdio_acpi_set_handle(struct sdio_func *func) {}
  #endif
  
@@ -122,7 +122,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
  /*
   * Register a new SDIO function with the driver model.
   */
-@@ -312,6 +321,7 @@ int sdio_add_func(struct sdio_func *func
+@@ -322,6 +331,7 @@ int sdio_add_func(struct sdio_func *func
  
        dev_set_name(&func->dev, "%s:%d", mmc_card_id(func->card), func->num);
  
@@ -130,7 +130,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
        sdio_acpi_set_handle(func);
        ret = device_add(&func->dev);
        if (ret == 0) {
-@@ -335,6 +345,7 @@ void sdio_remove_func(struct sdio_func *
+@@ -345,6 +355,7 @@ void sdio_remove_func(struct sdio_func *
  
        dev_pm_domain_detach(&func->dev, false);
        device_del(&func->dev);