kernel: update linux 3.3 to 3.3.5
authorGabor Juhos <juhosg@openwrt.org>
Mon, 7 May 2012 20:11:43 +0000 (20:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 7 May 2012 20:11:43 +0000 (20:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31645 3c298f89-4303-0410-b956-a3cf2f4a3e73

39 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/adm8668/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.3/003-MIPS-ath79-fix-AR933X-WMAC-reset-code.patch [deleted file]
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/brcm63xx/patches-3.3/401-MIPS-BCM63XX-register-ohci-device.patch
target/linux/brcm63xx/patches-3.3/403-MIPS-BCM63XX-register-ehci-device.patch
target/linux/brcm63xx/patches-3.3/404-bcm963xx_flashmap.patch
target/linux/brcm63xx/patches-3.3/408-6358-enet1-external-mii-clk.patch
target/linux/brcm63xx/patches-3.3/415-bcm63xx_enet-add-support-for-bcm6368-internal-ethern.patch
target/linux/brcm63xx/patches-3.3/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.3/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.3/750-hostap_txpower.patch
target/linux/generic/patches-3.3/830-ledtrig_morse.patch
target/linux/generic/patches-3.3/831-ledtrig_netdev.patch
target/linux/generic/patches-3.3/941-ocf_20110720.patch
target/linux/generic/patches-3.3/950-vm_exports.patch
target/linux/generic/patches-3.3/980-update_arm_machtypes.patch
target/linux/generic/patches-3.3/992-mpcore_wdt_fix_watchdog_counter_loading.patch
target/linux/ixp4xx/patches-3.3/600-skb_avoid_dmabounce.patch
target/linux/lantiq/patches-3.3/0055-MIPS-lantiq-udp-in-kernel-redirect.patch
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/omap4/Makefile
target/linux/ppc40x/Makefile
target/linux/pxa/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/uml/Makefile
target/linux/x86/geos/target.mk

index 820b784..7a97f89 100644 (file)
@@ -38,8 +38,8 @@ endif
 ifeq ($(LINUX_VERSION),3.2.16)
   LINUX_KERNEL_MD5SUM:=246e6bd28ea44c90ec66c7f8b56e4803
 endif
-ifeq ($(LINUX_VERSION),3.3.4)
-  LINUX_KERNEL_MD5SUM:=113baeccd2a3341ecc62ae5e73c2ed1d
+ifeq ($(LINUX_VERSION),3.3.5)
+  LINUX_KERNEL_MD5SUM:=2f6b7da0418e26312bcabd08ab448569
 endif
 
 # disable the md5sum check for unknown kernel versions
index 8c2d6f4..ea7f33a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index d0edaa3..39d6c7f 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Infineon WildPass ADM8668
 FEATURES:=squashfs
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
index 1e7d1a3..74fe9d1 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index fa18d21..c479a44 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ar71xx/patches-3.3/003-MIPS-ath79-fix-AR933X-WMAC-reset-code.patch b/target/linux/ar71xx/patches-3.3/003-MIPS-ath79-fix-AR933X-WMAC-reset-code.patch
deleted file mode 100644 (file)
index e5807c7..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 51233d66e030239f99755b2983753eff9b748365 Mon Sep 17 00:00:00 2001
-From: Gabor Juhos <juhosg@openwrt.org>
-Date: Wed, 14 Mar 2012 10:28:35 +0100
-Subject: [PATCH 04/47] MIPS: ath79: fix AR933X WMAC reset code
-
-The current code puts the built-in WMAC device of the
-AR933X SoCs into reset instead of starting it. This
-causes a hard lock on AR933X based boards when the
-wireless driver tries to access the device.
-
-Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
-Cc: stable@vger.kernel.org
-Cc: linux-mips@linux-mips.org
-Patchwork: https://patchwork.linux-mips.org/patch/3484/
-Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
----
- arch/mips/ath79/dev-wmac.c |    2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
---- a/arch/mips/ath79/dev-wmac.c
-+++ b/arch/mips/ath79/dev-wmac.c
-@@ -58,8 +58,8 @@ static void __init ar913x_wmac_setup(voi
- static int ar933x_wmac_reset(void)
- {
--      ath79_device_reset_clear(AR933X_RESET_WMAC);
-       ath79_device_reset_set(AR933X_RESET_WMAC);
-+      ath79_device_reset_clear(AR933X_RESET_WMAC);
-       return 0;
- }
index 01d942a..c9e04c5 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 SUBTARGETS:=9g20 9260 9263
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index e251f21..77d7fad 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 8ff370e..89e929e 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 70b7dab..bc2b6a3 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index f00704b..41c98c1 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index aad6c5c..7b213c3 100644 (file)
@@ -66,7 +66,7 @@ Subject: [PATCH 24/63] MIPS: BCM63XX: register ohci device.
  #include <board_bcm963xx.h>
  #include <bcm_tag.h>
  
-@@ -944,6 +945,9 @@ int __init board_register_devices(void)
+@@ -943,6 +944,9 @@ int __init board_register_devices(void)
            !board_get_mac_address(board.enet1.mac_addr))
                bcm63xx_enet_register(1, &board.enet1);
  
index fec36ea..5021ab4 100644 (file)
@@ -49,7 +49,7 @@ Subject: [PATCH 26/63] MIPS: BCM63XX: register ehci device.
  #include <board_bcm963xx.h>
  #include <bcm_tag.h>
  
-@@ -945,6 +946,9 @@ int __init board_register_devices(void)
+@@ -944,6 +945,9 @@ int __init board_register_devices(void)
            !board_get_mac_address(board.enet1.mac_addr))
                bcm63xx_enet_register(1, &board.enet1);
  
index a2d38d4..002f5a1 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -876,7 +876,7 @@ static struct mtd_partition mtd_partitio
+@@ -875,7 +875,7 @@ static struct mtd_partition mtd_partitio
        }
  };
  
index f4cfe0b..ac7dd6e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -848,6 +848,8 @@ void __init board_prom_init(void)
+@@ -847,6 +847,8 @@ void __init board_prom_init(void)
                if (BCMCPU_IS_6348())
                        val |= GPIO_MODE_6348_G3_EXT_MII |
                                GPIO_MODE_6348_G0_EXT_MII;
index dcbbd29..e4da9fa 100644 (file)
@@ -13,7 +13,7 @@ Subject: [PATCH 31/63] bcm63xx_enet: add support for bcm6368 internal ethernet s
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -948,6 +948,10 @@ int __init board_register_devices(void)
+@@ -947,6 +947,10 @@ int __init board_register_devices(void)
            !board_get_mac_address(board.enet1.mac_addr))
                bcm63xx_enet_register(1, &board.enet1);
  
index 2a86d35..da8b003 100644 (file)
@@ -95,7 +95,7 @@
  
        /* dump cfe version */
        cfe = boot_addr + BCM963XX_CFE_VERSION_OFFSET;
-@@ -2161,6 +2235,13 @@ int __init board_register_devices(void)
+@@ -2160,6 +2234,13 @@ int __init board_register_devices(void)
        val = bcm_mpi_readl(MPI_CSBASE_REG(0));
        val &= MPI_CSBASE_BASE_MASK;
  
index e5fdeea..3efa29e 100644 (file)
@@ -102,8 +102,8 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static void __init nb4_nvram_fixup(void)
-@@ -2283,12 +2361,25 @@ void __init board_prom_init(void)
-               bcm63xx_pci_enabled = 1;
+@@ -2282,12 +2360,25 @@ void __init board_prom_init(void)
+       if (board.has_pci) {
                if (BCMCPU_IS_6348())
                        val |= GPIO_MODE_6348_G2_PCI;
 +
index 600ff85..ec0685a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index a928bcd..8e2ec9a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/hostap/hostap_ap.c
 +++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2340,13 +2340,13 @@ int prism2_ap_get_sta_qual(local_info_t 
+@@ -2340,13 +2340,13 @@ int prism2_ap_get_sta_qual(local_info_t
                addr[count].sa_family = ARPHRD_ETHER;
                memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
                if (sta->last_rx_silence == 0)
index 47db802..3283807 100644 (file)
@@ -11,7 +11,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -57,3 +57,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += 
+@@ -57,3 +57,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
  obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)  += ledtrig-backlight.o
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
index 161db1a..7f94b1c 100644 (file)
@@ -14,7 +14,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -58,3 +58,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += 
+@@ -58,3 +58,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
  obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
index 715d4fa..5ff399e 100644 (file)
@@ -34,7 +34,7 @@
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
-@@ -726,6 +736,63 @@ void add_disk_randomness(struct gendisk 
+@@ -726,6 +736,63 @@ void add_disk_randomness(struct gendisk
  }
  #endif
  
index b9abd0c..1cd970c 100644 (file)
@@ -61,7 +61,7 @@
  {
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -3855,6 +3855,7 @@ int can_nice(const struct task_struct *p
+@@ -3854,6 +3854,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
index 7d49ce9..391511c 100644 (file)
  pluto                 MACH_PLUTO              PLUTO                   3869
  acfx100                       MACH_ACFX100            ACFX100                 3870
  msm8625_rumi3         MACH_MSM8625_RUMI3      MSM8625_RUMI3           3871
-@@ -1161,6 +3833,8 @@ valente_wx               MACH_VALENTE_WX         VALENTE_WX      
+@@ -1161,6 +3833,8 @@ valente_wx               MACH_VALENTE_WX         VALENTE_WX
  huangshans            MACH_HUANGSHANS         HUANGSHANS              3879
  bosphorus1            MACH_BOSPHORUS1         BOSPHORUS1              3880
  prima                 MACH_PRIMA              PRIMA                   3881
index a476952..fb16e2a 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Vitaly Kuzmichev <vkuzmichev@mvista.com>
 +EXPORT_SYMBOL_GPL(twd_timer_get_rate);
 --- a/drivers/watchdog/mpcore_wdt.c
 +++ b/drivers/watchdog/mpcore_wdt.c
-@@ -99,9 +99,7 @@ static void mpcore_wdt_keepalive(struct 
+@@ -99,9 +99,7 @@ static void mpcore_wdt_keepalive(struct
  
        spin_lock(&wdt_lock);
        /* Assume prescale is set to 256 */
index f48c273..625b768 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/core/skbuff.c
 +++ b/net/core/skbuff.c
-@@ -176,6 +176,10 @@ struct sk_buff *__alloc_skb(unsigned int
+@@ -177,6 +177,10 @@ struct sk_buff *__alloc_skb(unsigned int
        struct sk_buff *skb;
        u8 *data;
  
@@ -11,7 +11,7 @@
        cache = fclone ? skbuff_fclone_cache : skbuff_head_cache;
  
        /* Get the HEAD */
-@@ -929,6 +933,10 @@ int pskb_expand_head(struct sk_buff *skb
+@@ -946,6 +950,10 @@ int pskb_expand_head(struct sk_buff *skb
        if (skb_shared(skb))
                BUG();
  
index 15e704d..98b43ab 100644 (file)
@@ -75,7 +75,7 @@ Subject: [PATCH 55/70] MIPS: lantiq: udp in-kernel redirect
 +#endif
 --- a/net/Kconfig
 +++ b/net/Kconfig
-@@ -72,6 +72,12 @@ config INET
+@@ -78,6 +78,12 @@ config INET
  
          Short answer: say Y.
  
index fbe5974..fc68528 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 602e470..e027ed5 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index e8f9470..7914c22 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index be6bac2..92680e5 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=omap4
 BOARDNAME:=TI OMAP4
 FEATURES:=usb targz audio display
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
index 164a039..3fe2692 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 23cba7b..472b7bf 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=squashfs broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 7241be7..6ac3901 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 2d65c93..33b9219 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 9bf8487..5451971 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb pcmcia broken
 CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 66171fe..9c94c43 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
index cd4c7cf..bf9fc9c 100644 (file)
@@ -1,4 +1,4 @@
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
 BOARDNAME:=Traverse Geos
 FEATURES:=squashfs jffs2 ext4 pci usb gpio
 DEFAULT_PACKAGES += \