libreadline: bump to 6.3
authorSteven Barth <steven@midlink.org>
Mon, 15 Sep 2014 10:15:23 +0000 (10:15 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 15 Sep 2014 10:15:23 +0000 (10:15 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42543 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/libreadline/Makefile

index 0ce11a3..5a63271 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=readline
-PKG_VERSION:=6.2
+PKG_VERSION:=6.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/readline
-PKG_MD5SUM:=67948acb2ca081f23359d0256e9a271c
+PKG_MD5SUM:=33c8fb279e981274f485fd91da77e94a
 
 PKG_LICENSE:=GPLv3
 PKG_LICENSE_FILES:=COPYING
@@ -44,6 +44,8 @@ define Build/Configure
                --enable-shared \
                --enable-static \
                --without-curses \
+               bash_cv_wcwidth_broken=no \
+               bash_cv_func_sigsetjmp=yes \
        )
 endef
 
@@ -61,12 +63,12 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.6,so.6.2} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.6,so.6.3} $(1)/usr/lib/
 endef
 
 define Package/libreadline/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.6,so.6.2} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.6,so.6.3} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libreadline))