generic: relocate: make the cacheline size configurable
authorJonas Gorski <jogo@openwrt.org>
Mon, 30 Mar 2015 20:20:10 +0000 (20:20 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 30 Mar 2015 20:20:10 +0000 (20:20 +0000)
Different targets have different cache line sizes.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45163 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/image/relocate/Makefile

index 500423b..5f6ebeb 100644 (file)
@@ -22,6 +22,7 @@ BOARD         :=
 FLASH_OFFS     :=
 FLASH_MAX      :=
 PLATFORM       :=
+CACHELINE_SIZE := 32
 
 CC             := $(CROSS_COMPILE)gcc
 LD             := $(CROSS_COMPILE)ld
@@ -36,7 +37,8 @@ CFLAGS                = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-common -ffreestanding -fhonour-copts \
                  -mabi=32 -march=mips32r2 \
                  -Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap \
-                 -DCONFIG_CACHELINE_SIZE=32 -DKERNEL_ADDR=$(KERNEL_ADDR)
+                 -DCONFIG_CACHELINE_SIZE=$(CACHELINE_SIZE) \
+                 -DKERNEL_ADDR=$(KERNEL_ADDR)
 
 ASFLAGS                = $(CFLAGS) -D__ASSEMBLY__