BB: px5g-standalone: use /dev/urandom to initialize serial (#18232)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 27 Oct 2014 11:09:37 +0000 (11:09 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 27 Oct 2014 11:09:37 +0000 (11:09 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Backport of r43080

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@43083 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/px5g-standalone/Makefile
package/utils/px5g-standalone/src/library/x509write.c

index fc5f391..d6843b0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=px5g
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CHECK_FORMAT_SECURITY:=0
index fabee20..1091568 100644 (file)
@@ -1000,6 +1000,26 @@ static int x509write_make_sign(x509_raw *chain, rsa_context *privkey)
 }
 
 /*
+ * Create a random serial
+ */
+static int get_random_serial(void)
+{
+    int random = 0;
+    FILE *fd;
+
+    fd = fopen("/dev/urandom", "r");
+
+    if (fd) {
+       if (fread(&random, 1, sizeof(random), fd) != sizeof(random))
+            random = 0;
+
+        fclose(fd);
+    }
+
+    return random;
+}
+
+/*
  * Create a self signed certificate
  */
 int x509write_create_sign(x509_raw *chain, rsa_context *privkey)
@@ -1020,8 +1040,11 @@ int x509write_create_sign(x509_raw *chain, rsa_context *privkey)
     /*
      *  CertificateSerialNumber  ::=  INTEGER
      */
-    srand((unsigned int) time(NULL));
-    serial = rand();
+    serial = get_random_serial();
+
+    if (serial == 0)
+        return 1;
+
     if ((ret = asn1_add_int(serial, &chain->serial)) != 0)
         return ret;