AA: packages: samba36: fix segmentation fault when trying to add non-existent users
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Feb 2013 12:45:52 +0000 (12:45 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Feb 2013 12:45:52 +0000 (12:45 +0000)
Backport of r35610.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_12.09@35772 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/samba36/Makefile
net/samba36/patches/111-owrt_smbpasswd.patch

index 2a6b6b6..f519a21 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/old-versions
index d8089a3..aebe095 100644 (file)
 +      }
 +
 +      if (!find_passwd_line(fp, user, &p1)) {
-+              printf("User %s not found or invalid in /etc/passwd\n");
++              printf("User %s not found or invalid in /etc/passwd\n", user);
 +              goto out;
 +      }
 +