miniupnpc: backport of r35521
authoryardley <yardley@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Feb 2013 21:04:13 +0000 (21:04 +0000)
committeryardley <yardley@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Feb 2013 21:04:13 +0000 (21:04 +0000)
Signed-off-by: Tim Yardley <yardley@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_12.09@35526 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/miniupnpc/Makefile
net/miniupnpc/patches/100-no_minixml_test.patch
net/miniupnpc/patches/200-miniupnpc_desc.patch

index 1692d43..159e05f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpc
-PKG_VERSION:=1.6
+PKG_VERSION:=1.8
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=88055f2d4a061cfd4cfe25a9eae22f67
+PKG_MD5SUM:=065bf20a20ebe605c675b7a5aaef340a
 
 PKG_INSTALL:=1
 
@@ -43,6 +43,7 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 MAKE_FLAGS += \
+       OS="Linux" \
        PREFIX="$(PKG_INSTALL_DIR)"
 
 define Build/InstallDev
index e549ef0..93f6772 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -107,8 +107,8 @@ installpythonmodule:       pythonmodule
-       python setup.py install
+@@ -151,8 +151,8 @@ installpythonmodule3:      pythonmodule3
+       python3 setup.py install
  
  validateminixml:      minixmlvalid
 -      @echo "minixml validation test"
@@ -10,4 +10,4 @@
 +#     ./minixmlvalid
        touch $@
  
- clean:
+ validateminiwget:     testminiwget minihttptestserver testminiwget.sh
index 9a38847..320707e 100644 (file)
@@ -1,11 +1,11 @@
 --- a/upnpcommands.c
 +++ b/upnpcommands.c
-@@ -351,7 +351,7 @@ UPNP_AddPortMapping(const char * control
+@@ -367,7 +367,7 @@ UPNP_AddPortMapping(const char * control
        AddPortMappingArgs[5].elt = "NewEnabled";
        AddPortMappingArgs[5].val = "1";
        AddPortMappingArgs[6].elt = "NewPortMappingDescription";
 -      AddPortMappingArgs[6].val = desc?desc:"libminiupnpc";
 +      AddPortMappingArgs[6].val = desc?desc:"miniupnpc";
        AddPortMappingArgs[7].elt = "NewLeaseDuration";
-       AddPortMappingArgs[7].val = "0";
-       if(simpleUPnPcommand(-1, controlURL, servicetype, "AddPortMapping", AddPortMappingArgs, buffer, &bufsize) < 0) {
+       AddPortMappingArgs[7].val = leaseDuration?leaseDuration:"0";
+       if(!(buffer = simpleUPnPcommand(-1, controlURL, servicetype,