[kernel] update 2.6.35.x to 2.6.35.7
[openwrt.git] / target / linux / kirkwood / modules.mk
index ed7fe88..736c82c 100644 (file)
@@ -2,10 +2,10 @@
 define KernelPackage/crypto-mv_cesa
    TITLE:=Marvell crypto engine
    KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/crypto/mv_cesa.ko
+   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
    AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
    SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core
+   DEPENDS:=kmod-crypto-core @TARGET_kirkwood
 endef
 
 $(eval $(call KernelPackage,crypto-mv_cesa))