[packages_10.03.2] kissdx: merge r28965, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 03:42:41 +0000 (03:42 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 03:42:41 +0000 (03:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30189 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/kissdx/Makefile
multimedia/kissdx/files/kissdx.init

index 854732f..dbd94ec 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kissdx
 PKG_VERSION:=0.14.0.b1a
-PKG_RELEASE:=7
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
 PKG_SOURCE_URL:=http://kissdx.vidartysse.net
@@ -52,4 +52,8 @@ define Package/kissdx/install
        $(INSTALL_BIN) ./files/kissdx.init $(1)/etc/init.d/kissdx
 endef
 
+define Package/kissdx/conffiles
+/etc/config/kissdx
+endef
+
 $(eval $(call BuildPackage,kissdx))
index c3b5dcb..847be81 100755 (executable)
@@ -2,6 +2,9 @@
 # Copyright (C) 2008 OpenWrt.org
 
 START=65
+
+SERVICE_USE_PID=1
+
 CFGFILE=/tmp/kissdx.conf
 
 create_configfile() {
@@ -98,9 +101,9 @@ create_configfile() {
 start () {
        config_load kissdx
        create_configfile
-       /usr/bin/kissdx -c $CFGFILE -d
+       service_start /usr/bin/kissdx -c $CFGFILE -d
 }
 
 stop() {
-       killall -9 kissdx
+       service_stop /usr/bin/kissdx
 }