[packages_10.03.2] spandsp: merge r29792
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:49:44 +0000 (18:49 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:49:44 +0000 (18:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30064 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/spandsp/Makefile
libs/spandsp/patches/100-compile-fixes.patch

index 1b6ea59..e2054a0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=spandsp
 PKG_VERSION:=0.0.6
 PKG_VERSION_SUFFIX:=pre17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)$(PKG_VERSION_SUFFIX).tgz
 PKG_SOURCE_URL:=http://www.soft-switch.org/downloads/spandsp/
@@ -19,6 +19,7 @@ PKG_MD5SUM:=cc860f77270cf3b881f8ccd42d2d0238
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,8 +30,6 @@ define Package/libspandsp
   DEPENDS:=+libtiff
 endef
 
-CONFIGURE_ARGS+= LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
-
 TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev
index 367dc95..afe9e33 100644 (file)
@@ -1,8 +1,6 @@
-Index: spandsp-0.0.6/src/spandsp/fast_convert.h
-===================================================================
---- spandsp-0.0.6.orig/src/spandsp/fast_convert.h      2010-10-24 12:20:25.000000000 +0200
-+++ spandsp-0.0.6/src/spandsp/fast_convert.h   2010-10-24 12:21:39.000000000 +0200
-@@ -197,7 +197,7 @@
+--- a/src/spandsp/fast_convert.h
++++ b/src/spandsp/fast_convert.h
+@@ -197,7 +197,7 @@ extern "C"
      {
          return (long int) (x);
      }
@@ -11,3 +9,15 @@ Index: spandsp-0.0.6/src/spandsp/fast_convert.h
      static __inline__ long int lfastrint(register double x)
      {
          int res[2];
+--- a/configure.ac
++++ b/configure.ac
+@@ -152,9 +152,7 @@ AC_ARG_ENABLE(builtin_tiff,
+ AC_FUNC_ERROR_AT_LINE
+ AC_FUNC_VPRINTF
+-AC_FUNC_MALLOC
+ AC_FUNC_MEMCMP
+-AC_FUNC_REALLOC
+ AC_FUNC_SELECT_ARGTYPES
+ AX_C99_FUNC_LRINT