[packages_10.03.2] aiccu: backport r32666
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jul 2012 14:04:41 +0000 (14:04 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jul 2012 14:04:41 +0000 (14:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@32667 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/aiccu/Makefile
ipv6/aiccu/files/aiccu.conf [deleted file]
ipv6/aiccu/files/aiccu.hotplug [deleted file]
ipv6/aiccu/files/aiccu.init [deleted file]

index 496fce4..9997c91 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
-PKG_RELEASE:=6
+PKG_RELEASE:=6.1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+libpthread +ip +kmod-sit +kmod-tun
+  DEPENDS:=+libpthread
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
   URL:=http://www.sixxs.net/tools/aiccu/
 endef
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
   URL:=http://www.sixxs.net/tools/aiccu/
 endef
@@ -46,12 +46,6 @@ endef
 define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
 define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/config/aiccu
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/aiccu.hotplug $(1)/etc/hotplug.d/iface/30-aiccu
 endef
 
 $(eval $(call BuildPackage,aiccu))
 endef
 
 $(eval $(call BuildPackage,aiccu))
diff --git a/ipv6/aiccu/files/aiccu.conf b/ipv6/aiccu/files/aiccu.conf
deleted file mode 100755 (executable)
index 671fd16..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-config aiccu
-       option username         ''
-       option password         ''
-       option protocol         ''
-       option server           ''
-       option interface        ''
-       option tunnel_id        ''
-       option requiretls       ''
-       option defaultroute     '1'
-       option nat              '1'
-       option heartbeat        '1'
diff --git a/ipv6/aiccu/files/aiccu.hotplug b/ipv6/aiccu/files/aiccu.hotplug
deleted file mode 100644 (file)
index b886976..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /etc/init.d/aiccu enabled && /etc/init.d/aiccu start
diff --git a/ipv6/aiccu/files/aiccu.init b/ipv6/aiccu/files/aiccu.init
deleted file mode 100644 (file)
index 68bac20..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-START=51
-
-config_cb() {
-       local cfg_type="$1"
-       local cfg_name="$2"
-
-       case "$cfg_type" in
-               aiccu)
-                       append cfgs_sections "$cfg_name" "$N"
-               ;;
-       esac
-}
-
-start() {
-       config_load aiccu
-       for cfgs_section in $cfgs_sections; do
-               config_get username $cfgs_section username
-               config_get password $cfgs_section password
-               config_get server $cfgs_section server
-               config_get protocol $cfgs_section protocol
-               config_get interface $cfgs_section interface
-               config_get tunnel_id $cfgs_section tunnel_id
-               config_get_bool requiretls $cfgs_section requiretls 0
-               config_get_bool defaultroute $cfgs_section defaultroute 1
-               config_get_bool nat $cfgs_section nat 1
-               config_get_bool heartbeat $cfgs_section heartbeat 1
-               mkdir -p /tmp/run
-               echo "username $username" > /tmp/run/aiccu-${cfgs_section}.conf
-               echo "password $password" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ -n "$server" ] && echo "server $server" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ -n "$protocol" ] && echo "protocol $protocol" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ -n "$interface" ] && echo "ipv6_interface $interface" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ -n "$tunnel_id" ] && echo "tunnel_id $tunnel_id" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ "$requiretls" = "1" ] && echo "requiretls true" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ "$defaultroute" != "1" ] && echo "defaultroute false" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ "$nat" = "1" ] && echo "behindnat true" >> /tmp/run/aiccu-${cfgs_section}.conf
-               [ "$heartbeat" != "1" ] && echo "makebeats false" >> /tmp/run/aiccu-${cfgs_section}.conf
-               echo 'daemonize true' >> /tmp/run/aiccu-${cfgs_section}.conf
-               echo "pidfile /var/run/aiccu-${cfgs_section}.pid" >> /tmp/run/aiccu-${cfgs_section}.conf
-       
-               aiccu start /tmp/run/aiccu-$cfgs_section.conf
-       done
-}
-
-stop() {
-       config_load aiccu
-       for cfgs_section in $cfgs_sections; do
-               aiccu stop /tmp/run/aiccu-$cfgs_section.conf
-       done
-}