[packages_10.03.2] iodine: merge r29059, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 15:18:02 +0000 (15:18 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 15:18:02 +0000 (15:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30209 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/iodine/Makefile
net/iodine/files/iodined.init

index 05e4743..03535b8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iodine
 PKG_VERSION:=0.6.0-rc1
-PKG_RELEASE:=3
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://code.kryo.se/iodine/
@@ -61,5 +61,9 @@ define Package/iodined/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodined $(1)/usr/sbin
 endef
 
+define Package/iodined/conffiles
+/etc/config/iodined
+endef
+
 $(eval $(call BuildPackage,iodine))
 $(eval $(call BuildPackage,iodined))
index 1eac807..d91b779 100644 (file)
@@ -1,22 +1,23 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-start_service () {
+start_instance () {
        local section="$1"
-       config_get address  "$section" address
-       config_get password "$section" password
-       config_get tunnelip "$section" tunnelip
-       config_get tld      "$section" tld
+       config_get address  "$section" 'address'
+       config_get password "$section" 'password'
+       config_get tunnelip "$section" 'tunnelip'
+       config_get tld      "$section" 'tld'
        
-       iodined -l $address -P $password $tunnelip $tld
+       service_start /usr/sbin/iodined -l "$address" -P "$password" "$tunnelip" "$tld"
 }
 
 start() {
-       config_load "iodined"
-       config_foreach start_service iodined
+       config_load 'iodined'
+       config_foreach start_instance 'iodined'
 }
 
 stop() {
-       killall iodined
+       service_stop /usr/sbin/iodined
 }