libnet-1.0.x: remove CFLAGS hardcoding
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:37 +0000 (00:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:37 +0000 (00:56 +0000)
configure.in contains a test which overrides CFLAGS with CCOPTS when it
determines that the compiler is GCC, this breaks build on most platforms where
the ABI has to be explicitely specified (e.g: ARM VFP).

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39800 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libnet-1.0.x/Makefile
libs/libnet-1.0.x/patches/200-no_cflags_ovveride.patch [new file with mode: 0644]

index e21b796..c35b7ee 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnet0
 PKG_VERSION:=1.0.2a
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_SOURCE:=libnet-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.packetfactory.net/libnet/dist/deprecated/
diff --git a/libs/libnet-1.0.x/patches/200-no_cflags_ovveride.patch b/libs/libnet-1.0.x/patches/200-no_cflags_ovveride.patch
new file mode 100644 (file)
index 0000000..23f8a25
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/configure.in     2014-03-06 14:55:36.627221831 -0800
++++ b/configure.in     2014-03-06 14:56:48.709112089 -0800
+@@ -53,16 +53,6 @@
+ dnl
+-dnl Use these compiler flags if we have gcc.
+-dnl
+-if test $ac_cv_prog_gcc = yes; then
+-dnl if test -z $CFLAGS; then 
+-    CCOPTS='-O2 -funroll-loops -fomit-frame-pointer -Wall'
+-    CFLAGS="$CCOPTS"
+-dnl fi
+-fi
+-
+-dnl
+ dnl Check for package inclusion/exclusion
+ dnl
+ AC_ARG_WITH(pf_packet, [ --with-pf_packet=[yes,no] override defaults], \