cksfv: add missing inttypes.h inclusion
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:34 +0000 (00:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:34 +0000 (00:56 +0000)
Build was failing because inttypes.h did not provide a declaration for uint32_t
and friends

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39799 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/cksfv/Makefile
utils/cksfv/patches/001-missing_inttypes_h.patch [new file with mode: 0644]

index ca40189..aac72fd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cksfv
 PKG_VERSION:=1.3.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://zakalwe.fi/~shd/foss/cksfv/files
diff --git a/utils/cksfv/patches/001-missing_inttypes_h.patch b/utils/cksfv/patches/001-missing_inttypes_h.patch
new file mode 100644 (file)
index 0000000..1580d63
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/cksfv.h      2009-04-12 09:04:10.000000000 -0700
++++ b/src/cksfv.h      2014-03-06 14:18:21.020889903 -0800
+@@ -5,6 +5,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <inttypes.h>
+ #include "config.h"
+--- a/src/crc32.c      2009-04-12 09:04:10.000000000 -0700
++++ b/src/crc32.c      2014-03-06 14:44:20.836871963 -0800
+@@ -18,6 +18,7 @@
+ #include <unistd.h>
+ #include <errno.h>
++#include <inttypes.h>
+ #include "config.h"