check: moved to github
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 10:24:32 +0000 (10:24 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 10:24:32 +0000 (10:24 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@44300 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/check/Makefile [deleted file]

diff --git a/libs/check/Makefile b/libs/check/Makefile
deleted file mode 100644 (file)
index 5444079..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-#
-# Copyright (C) 2008-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=check
-PKG_VERSION:=0.9.8
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/check
-PKG_MD5SUM:=5d75e9a6027cde79d2c339ef261e7470
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-TARGET_CFLAGS += $(FPIC)
-
-define Package/check
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Unit testing framework for C
-  URL:=http://check.sourceforge.net/
-  DEPENDS:= +libpthread
-endef
-
-define Package/check/description
-  Check features a simple interface for defining unit tests, putting little in
-  the way of the developer. Tests are run in a separate address space, so Check
-  can catch both assertion failures and code errors that cause segmentation
-  faults or other signals. The output from unit tests can be used within source
-  code editors and IDEs.
-endef
-
-define Build/Configure
-       $(CP) $(SCRIPT_DIR)/config.* $(PKG_BUILD_DIR)/build-aux/
-       $(call Build/Configure/Default)
-endef
-
-define Build/Install
-       $(call Build/Install/Default)
-       cd $(PKG_INSTALL_DIR)/usr/lib/ ; ln -nsf libcheck.so libcheck_pic.so
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
-
-define Package/check/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcheck.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,check))