keepalived: moved to github
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 10:24:29 +0000 (10:24 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 10:24:29 +0000 (10:24 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@44299 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/keepalived/Makefile [deleted file]
net/keepalived/files/keepalived.init [deleted file]

diff --git a/net/keepalived/Makefile b/net/keepalived/Makefile
deleted file mode 100644 (file)
index 3a0e430..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-#
-# Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=keepalived
-PKG_VERSION:=1.1.19
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:= http://www.keepalived.org/software
-PKG_MD5SUM:=a35b8d9d462810f7650d292bd7457523
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-define Package/keepalived
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=Failover and monitoring daemon for LVS clusters
-  URL:=http://www.keepalived.org/
-  DEPENDS:=+libpopt +libopenssl
-endef
-
-define Package/keepalived/description
- Failover and monitoring daemon for Linux Virtual Server (LVS) clusters.
-endef
-
-define Package/keepalived/conffiles
-/etc/keepalived/keepalived.conf
-endef
-
-acvar=$(subst -,_,$(subst .,_,$(subst /,_,$(1))))
-
-CONFIGURE_ARGS+= \
-       --enable-shared \
-       --disable-static \
-       --disable-debug \
-       --disable-strip \
-       --disable-lvs \
-       --disable-lvs-syncd \
-       --with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)"
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               STRIP="/bin/true" \
-               all install
-endef
-
-define Package/keepalived/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/etc/keepalived
-       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/keepalived.init $(1)/etc/init.d/keepalived
-endef
-
-$(eval $(call BuildPackage,keepalived))
diff --git a/net/keepalived/files/keepalived.init b/net/keepalived/files/keepalived.init
deleted file mode 100644 (file)
index 2807f92..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2007-2011 OpenWrt.org
-
-START=70
-
-SERVICE_USE_PID=1
-
-start() {
-       service_start /usr/sbin/keepalived
-}
-
-stop() {
-       service_stop /usr/sbin/keepalived
-}