[packages] minidlna: update to 1.0.24 (#11126)
authorswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Mar 2012 20:31:54 +0000 (20:31 +0000)
committerswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Mar 2012 20:31:54 +0000 (20:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30990 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/minidlna/Makefile
multimedia/minidlna/patches/010-genconfig-checks.patch
multimedia/minidlna/patches/020-makefile-tweaks.patch

index b9bee58..abf4813 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=minidlna
-PKG_VERSION:=1.0.22
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.24
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_src.tar.gz
 PKG_SOURCE_URL:=@SF/minidlna
-PKG_MD5SUM:=3de2f6b54f43bb998dfad3c8fa75cef3
+PKG_MD5SUM:=be9b4c91e3fcde592dc3f9828098ca0f
 
 PKG_BUILD_PARALLEL:=0
 
index 7e3be03..bce8456 100644 (file)
@@ -1,6 +1,6 @@
 --- a/genconfig.sh
 +++ b/genconfig.sh
-@@ -24,14 +24,18 @@ RM="rm -f"
+@@ -23,14 +23,18 @@ RM="rm -f"
  CONFIGFILE="config.h"
  CONFIGMACRO="__CONFIG_H__"
  
@@ -23,7 +23,7 @@
  TIVO="/*#define TIVO_SUPPORT*/"
  NETGEAR="/*#define NETGEAR*/"
  READYNAS="/*#define READYNAS*/"
-@@ -41,22 +45,22 @@ ${RM} ${CONFIGFILE}
+@@ -40,22 +44,22 @@ ${RM} ${CONFIGFILE}
  
  # Detect if there are missing headers
  # NOTE: This check only works with a normal distro
@@ -62,7 +62,7 @@
  if [ -n "$MISSING" ]; then
        echo -e "\nERROR!  Cannot continue."
        echo -e "The following required libraries are either missing, or are missing development headers:\n"
-@@ -152,8 +156,7 @@ case $OS_NAME in
+@@ -151,8 +155,7 @@ case $OS_NAME in
                fi
                ;;
        *)
@@ -72,7 +72,7 @@
                ;;
  esac
  
-@@ -184,7 +187,7 @@ fi
+@@ -183,7 +186,7 @@ fi
  echo "" >> ${CONFIGFILE}
  
  echo "/* Enable if the system iconv.h exists.  ID3 tag reading in various character sets will not work properly otherwise. */" >> ${CONFIGFILE}
@@ -81,7 +81,7 @@
  echo "#define HAVE_ICONV_H" >> ${CONFIGFILE}
  else
  echo -e "\nWARNING!!  Iconv support not found.  ID3 tag reading may not work."
-@@ -193,7 +196,7 @@ fi
+@@ -192,7 +195,7 @@ fi
  echo "" >> ${CONFIGFILE}
  
  echo "/* Enable if the system libintl.h exists for NLS support. */" >> ${CONFIGFILE}
index 887ebe4..8314d94 100644 (file)
@@ -37,7 +37,7 @@
  #STATIC_LINKING: LIBS = -lvorbis -logg -lm -lsqlite3 -lpthread -lexif -ljpeg -lFLAC -lm -lid3tag -lz -lavformat -lavutil -lavcodec -lm
  
  TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o
-@@ -62,7 +66,7 @@ install:     minidlna
+@@ -64,7 +68,7 @@ install-conf:
        $(INSTALL) -d $(ETCINSTALLDIR)
        $(INSTALL) --mode=0644 minidlna.conf $(ETCINSTALLDIR)