Add munin to /etc/services
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Mar 2012 19:42:07 +0000 (19:42 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Mar 2012 19:42:07 +0000 (19:42 +0000)
The muninlite postinst fails to add munin to /etc/services.

This patch removes this broken postinst and add an entry for munin in
/etc/services. This should have been done when the rest of the
/etc/services postinsts were being removed (changesets 26142-26149).

Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30983 3c298f89-4303-0410-b956-a3cf2f4a3e73

admin/muninlite/Makefile

index a55d3de..d241707 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=muninlite
 PKG_VERSION:=1.0.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -30,13 +30,6 @@ define Package/muninlite/Default/description
        Munin is a monitoring system for Unix networks.
 endef
 
-define Package/muninlite/postinst
-#!/bin/sh
-grep -q '^munin[[:space:]]*4949/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $$? -ne 0 ] && echo "munin       4949/tcp" >> $${IPKG_INSTROOT}/etc/services
-exit 0
-endef
-
 define Package/muninlite/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/munin-node $(1)/usr/sbin/