[package] xtables-addons: fix build for 64-bits targets
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 3 Aug 2012 13:32:39 +0000 (13:32 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 3 Aug 2012 13:32:39 +0000 (13:32 +0000)
The first fix is a pointer comparison fix, and the second is not to
override the Linux kernel's TARGET_LDFLAGS with those that we use
during cross-compiling.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@32958 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xtables-addons/Makefile
net/xtables-addons/patches/200-add-lua-packetscript.patch

index 7c5d1c9..27f170b 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
 PKG_VERSION:=1.42
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_MD5SUM:=7c996a0400667b57ab4fb53a013ae742
@@ -44,7 +44,6 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                DEPMOD="/bin/true" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
                all
 endef
 
@@ -54,7 +53,6 @@ define Build/Install
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                DEPMOD="/bin/true" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
                install
 endef
 
index af7d1bc..03fe5fa 100644 (file)
 +      else if (pskb->transport_header)
 +              p->start = pskb->transport_header;
 +      p->offset = 0;
-+      p->length = pskb->tail - p->start;
++      p->length = (unsigned long)pskb->tail - (unsigned long)p->start;
 +      p->changes = NULL;
 +
 +      /* marking userdata 'lua_packet_seg' with the corresponding metatable */