[packages_10.03.2] seeks: merge r29093
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:07:50 +0000 (16:07 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:07:50 +0000 (16:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30257 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/seeks/Makefile
net/seeks/files/seeks.init

index 4f72e9d..becf6da 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=seeks
 PKG_VERSION:=0.3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
index c636d6b..eb4c5e4 100644 (file)
@@ -1,21 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
-START=99
+# Copyright (C) 2011 OpenWrt.org
 
-DAEMON=/usr/bin/seeks
+START=99
 
 start() {
-       echo 'seeks is starting...'
-       start-stop-daemon -S -q -x "$DAEMON" -- --daemon
+       service_start /usr/bin/seeks --daemon
 }
 
 stop() {
-       echo 'seeks is stopping...'
-       start-stop-daemon -K -q -x "$DAEMON"
-}
-
-restart() {
-       stop
-       sleep 2
-       start
+       service_stop /usr/bin/seeks
 }