[packages_10.03.2] scanlogd: merge r28967
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:07:28 +0000 (16:07 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:07:28 +0000 (16:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30256 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/scanlogd/Makefile
net/scanlogd/files/scanlogd.init

index 81ae587..6b7305e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scanlogd
 PKG_VERSION:=2.2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openwall.com/scanlogd/ \
@@ -38,8 +38,9 @@ define Package/scanlogd/description
 endef
 
 define Build/Configure 
-       $(SED) "s,/var/empty,/tmp/.scanlogd," $(PKG_BUILD_DIR)/params.h
-       $(SED) "s,#undef SCANLOGD_DEVICE,#define SCANLOGD_DEVICE \"all\"," $(PKG_BUILD_DIR)/params.h
+       $(SED) 's,^#define \(SCANLOGD_CHROOT\).*,#define \1 "/var/run/scanlogd",' \
+           -e 's,^#undef \(SCANLOGD_DEVICE\),#define \1 "all",' \
+           $(PKG_BUILD_DIR)/params.h
 endef
 
 define Build/Compile   
index 8c6f382..cfe5825 100644 (file)
@@ -1,12 +1,19 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006 OpenWrt.org
+
 START=50
 
 start() {
-       mkdir -p `grep "^scanlogd:" /etc/passwd | cut -d: -f6`
-       /usr/sbin/scanlogd
+       user_exists scanlogd 51 || user_add scanlogd 51
+       group_exists scanlogd 51 || group_add scanlogd
+       [ -d  /var/run/scanlogd ] || {
+               mkdir -m 0755 -p /var/run/scanlogd
+               chmod 0755 /var/run/scanlogd
+               chown scanlogd:scanlogd /var/run/scanlogd
+       }
+       service_start /usr/sbin/scanlogd
 }
 
 stop() {
-       killall scanlogd
+       service_stop /usr/sbin/scanlogd
 }