tools: clean up Makefiles / make ccache work
[openwrt.git] / tools / ccache / Makefile
index ada9293..21123b3 100644 (file)
@@ -19,11 +19,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
   define Host/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(HOST_BUILD_DIR)
-  endef
-
-  define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(MAKE) CC="$(HOSTCC_NOCACHE)" -C $(HOST_BUILD_DIR)
   endef
 
   define Host/Clean
@@ -41,6 +37,8 @@ else
   endef
   define Host/Clean
   endef
+  define Download
+  endef
 endif
 
 $(eval $(call HostBuild))