binutils: remove linaro version string, it confuses gcc lto support detection
[openwrt.git] / toolchain / binutils / Makefile
index b88fbd8..820b5f8 100644 (file)
@@ -65,6 +65,7 @@ define Host/Prepare
        $(call Host/Prepare/Default)
        ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
+       $(SED) 's, " Linaro.*,,' $(HOST_BUILD_DIR)/bfd/version.h
 endef
 
 define Host/Configure