Add USR5461 image generation and tool (#817), thanks to Dick Streefland !
[openwrt.git] / target / utils / Makefile
index c7b9a04..d11d744 100644 (file)
@@ -6,7 +6,7 @@
 #
 include $(TOPDIR)/rules.mk
 
-TARGETS := addpattern trx motorola-bin dgfirmware
+TARGETS := addpattern trx motorola-bin dgfirmware trx2usr
 
 UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
 
@@ -27,6 +27,6 @@ $(UTILS_BUILD_DIR):
        mkdir -p $(UTILS_BUILD_DIR)
        
 $(UTILS_BUILD_DIR)/%: src/%.c
-       $(CC) -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
+       $(CC) -O2 -I $(STAGING_DIR)/include-host -include endian.h -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
        chmod 755 $@