[s3c24xx] bump to 2.6.30-rc6
[openwrt.git] / target / linux / s3c24xx / patches-2.6.30 / 052-touchscreen_filter.patch
diff --git a/target/linux/s3c24xx/patches-2.6.30/052-touchscreen_filter.patch b/target/linux/s3c24xx/patches-2.6.30/052-touchscreen_filter.patch
new file mode 100644 (file)
index 0000000..9125da1
--- /dev/null
@@ -0,0 +1,72 @@
+Index: linux-2.6.30-rc6/drivers/input/touchscreen/Kconfig
+===================================================================
+--- linux-2.6.30-rc6.orig/drivers/input/touchscreen/Kconfig    2009-05-18 19:08:31.000000000 +0200
++++ linux-2.6.30-rc6/drivers/input/touchscreen/Kconfig 2009-05-18 19:08:32.000000000 +0200
+@@ -11,6 +11,54 @@
+ if INPUT_TOUCHSCREEN
++menuconfig TOUCHSCREEN_FILTER
++      boolean "Touchscreen Filtering"
++      depends on INPUT_TOUCHSCREEN
++      select TOUCHSCREEN_FILTER_GROUP
++      select TOUCHSCREEN_FILTER_MEDIAN
++      select TOUCHSCREEN_FILTER_MEAN
++      select TOUCHSCREEN_FILTER_LINEAR
++      help
++        Select this to include kernel touchscreen filter support.  The filters
++        can be combined in any order in your machine init and the parameters
++        for them can also be set there.
++
++if TOUCHSCREEN_FILTER
++
++config TOUCHSCREEN_FILTER_GROUP
++      bool "Group Touchscreen Filter"
++      depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
++      default Y
++      help
++        Say Y here if you want to use the Group touchscreen filter, it
++        avoids using atypical samples.
++
++config TOUCHSCREEN_FILTER_MEDIAN
++      bool "Median Average Touchscreen Filter"
++      depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
++      default Y
++      help
++        Say Y here if you want to use the Median touchscreen filter, it's
++        highly effective if you data is noisy with occasional excursions.
++
++config TOUCHSCREEN_FILTER_MEAN
++      bool "Mean Average Touchscreen Filter"
++      depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
++      default Y
++      help
++        Say Y here if you want to use the Mean touchscreen filter, it
++        can further improve decent quality data by removing jitter
++
++config TOUCHSCREEN_FILTER_LINEAR
++      bool "Linear Touchscreen Filter"
++      depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
++      default Y
++      help
++        Say Y here if you want to use the Linear touchscreen filter, it
++        enables the use of calibration data for the touchscreen.
++
++endif
++
+ config TOUCHSCREEN_ADS7846
+       tristate "ADS7846/TSC2046 and ADS7843 based touchscreens"
+       depends on SPI_MASTER
+Index: linux-2.6.30-rc6/drivers/input/touchscreen/Makefile
+===================================================================
+--- linux-2.6.30-rc6.orig/drivers/input/touchscreen/Makefile   2009-05-18 19:08:31.000000000 +0200
++++ linux-2.6.30-rc6/drivers/input/touchscreen/Makefile        2009-05-18 19:08:32.000000000 +0200
+@@ -38,3 +38,8 @@
+ obj-$(CONFIG_TOUCHSCREEN_WM97XX_MAINSTONE)    += mainstone-wm97xx.o
+ obj-$(CONFIG_TOUCHSCREEN_WM97XX_ZYLONITE)     += zylonite-wm97xx.o
+ obj-$(CONFIG_TOUCHSCREEN_S3C2410)     += s3c2410_ts.o
++obj-$(CONFIG_TOUCHSCREEN_FILTER)      += ts_filter_chain.o
++obj-$(CONFIG_TOUCHSCREEN_FILTER_GROUP)        += ts_filter_group.o
++obj-$(CONFIG_TOUCHSCREEN_FILTER_LINEAR)       += ts_filter_linear.o
++obj-$(CONFIG_TOUCHSCREEN_FILTER_MEDIAN)       += ts_filter_median.o
++obj-$(CONFIG_TOUCHSCREEN_FILTER_MEAN) += ts_filter_mean.o