update to 2.6.30-rc7
[openwrt.git] / target / linux / s3c24xx / patches-2.6.30 / 050-s3c2442-touchscreen.patch
index 4015f93..c0de0e6 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.30-rc6/arch/arm/plat-s3c24xx/devs.c
-===================================================================
---- linux-2.6.30-rc6.orig/arch/arm/plat-s3c24xx/devs.c 2009-05-18 19:08:30.000000000 +0200
-+++ linux-2.6.30-rc6/arch/arm/plat-s3c24xx/devs.c      2009-05-18 19:08:31.000000000 +0200
+--- a/arch/arm/plat-s3c24xx/devs.c
++++ b/arch/arm/plat-s3c24xx/devs.c
 @@ -26,6 +26,8 @@
  #include <asm/mach/irq.h>
  #include <mach/fb.h>
@@ -11,7 +9,7 @@ Index: linux-2.6.30-rc6/arch/arm/plat-s3c24xx/devs.c
  #include <asm/irq.h>
  
  #include <plat/regs-serial.h>
-@@ -199,6 +201,24 @@
+@@ -199,6 +201,24 @@ struct platform_device s3c_device_nand =
  
  EXPORT_SYMBOL(s3c_device_nand);
  
@@ -36,11 +34,9 @@ Index: linux-2.6.30-rc6/arch/arm/plat-s3c24xx/devs.c
  /* USB Device (Gadget)*/
  
  static struct resource s3c_usbgadget_resource[] = {
-Index: linux-2.6.30-rc6/arch/arm/plat-s3c24xx/s3c244x.c
-===================================================================
---- linux-2.6.30-rc6.orig/arch/arm/plat-s3c24xx/s3c244x.c      2009-05-16 06:12:57.000000000 +0200
-+++ linux-2.6.30-rc6/arch/arm/plat-s3c24xx/s3c244x.c   2009-05-18 19:08:31.000000000 +0200
-@@ -59,6 +59,8 @@
+--- a/arch/arm/plat-s3c24xx/s3c244x.c
++++ b/arch/arm/plat-s3c24xx/s3c244x.c
+@@ -59,6 +59,8 @@ void __init s3c244x_init_uarts(struct s3
        s3c24xx_init_uartdevs("s3c2440-uart", s3c2410_uart_resources, cfg, no);
  }
  
@@ -49,7 +45,7 @@ Index: linux-2.6.30-rc6/arch/arm/plat-s3c24xx/s3c244x.c
  void __init s3c244x_map_io(void)
  {
        /* register our io-tables */
-@@ -70,6 +72,7 @@
+@@ -70,6 +72,7 @@ void __init s3c244x_map_io(void)
        s3c_device_sdi.name  = "s3c2440-sdi";
        s3c_device_i2c0.name  = "s3c2440-i2c";
        s3c_device_nand.name = "s3c2440-nand";
@@ -57,11 +53,9 @@ Index: linux-2.6.30-rc6/arch/arm/plat-s3c24xx/s3c244x.c
        s3c_device_usbgadget.name = "s3c2440-usbgadget";
  }
  
-Index: linux-2.6.30-rc6/drivers/input/touchscreen/Kconfig
-===================================================================
---- linux-2.6.30-rc6.orig/drivers/input/touchscreen/Kconfig    2009-05-16 06:12:57.000000000 +0200
-+++ linux-2.6.30-rc6/drivers/input/touchscreen/Kconfig 2009-05-18 19:08:31.000000000 +0200
-@@ -124,6 +124,24 @@
+--- a/drivers/input/touchscreen/Kconfig
++++ b/drivers/input/touchscreen/Kconfig
+@@ -124,6 +124,24 @@ config TOUCHSCREEN_FUJITSU
          To compile this driver as a module, choose M here: the
          module will be called fujitsu-ts.
  
@@ -86,19 +80,15 @@ Index: linux-2.6.30-rc6/drivers/input/touchscreen/Kconfig
  config TOUCHSCREEN_GUNZE
        tristate "Gunze AHL-51S touchscreen"
        select SERIO
-Index: linux-2.6.30-rc6/drivers/input/touchscreen/Makefile
-===================================================================
---- linux-2.6.30-rc6.orig/drivers/input/touchscreen/Makefile   2009-05-16 06:12:57.000000000 +0200
-+++ linux-2.6.30-rc6/drivers/input/touchscreen/Makefile        2009-05-18 19:08:31.000000000 +0200
-@@ -37,3 +37,4 @@
+--- a/drivers/input/touchscreen/Makefile
++++ b/drivers/input/touchscreen/Makefile
+@@ -37,3 +37,4 @@ wm97xx-ts-$(CONFIG_TOUCHSCREEN_WM9712)       +
  wm97xx-ts-$(CONFIG_TOUCHSCREEN_WM9713)        += wm9713.o
  obj-$(CONFIG_TOUCHSCREEN_WM97XX_MAINSTONE)    += mainstone-wm97xx.o
  obj-$(CONFIG_TOUCHSCREEN_WM97XX_ZYLONITE)     += zylonite-wm97xx.o
 +obj-$(CONFIG_TOUCHSCREEN_S3C2410)     += s3c2410_ts.o
-Index: linux-2.6.30-rc6/arch/arm/mach-s3c2410/include/mach/ts.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.30-rc6/arch/arm/mach-s3c2410/include/mach/ts.h   2009-05-18 19:08:31.000000000 +0200
+--- /dev/null
++++ b/arch/arm/mach-s3c2410/include/mach/ts.h
 @@ -0,0 +1,35 @@
 +/* arch/arm/mach-s3c2410/include/mach/ts.h
 + *
@@ -135,11 +125,9 @@ Index: linux-2.6.30-rc6/arch/arm/mach-s3c2410/include/mach/ts.h
 +void set_s3c2410ts_info(const struct s3c2410_ts_mach_info *hard_s3c2410ts_info);
 +
 +#endif /* __ASM_ARM_TS_H */
-Index: linux-2.6.30-rc6/arch/arm/plat-s3c/include/plat/devs.h
-===================================================================
---- linux-2.6.30-rc6.orig/arch/arm/plat-s3c/include/plat/devs.h        2009-05-18 19:07:48.000000000 +0200
-+++ linux-2.6.30-rc6/arch/arm/plat-s3c/include/plat/devs.h     2009-05-18 19:08:31.000000000 +0200
-@@ -50,10 +50,11 @@
+--- a/arch/arm/plat-s3c/include/plat/devs.h
++++ b/arch/arm/plat-s3c/include/plat/devs.h
+@@ -50,10 +50,11 @@ extern struct platform_device s3c_device
  
  extern struct platform_device s3c_device_usbgadget;