ramips: add subtarget for mt7688
[openwrt.git] / target / linux / ramips / mt7688 / profiles / 01-mediatek.mk
diff --git a/target/linux/ramips/mt7688/profiles/01-mediatek.mk b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
new file mode 100644 (file)
index 0000000..02190dd
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/mt7688
+       NAME:=mt7688
+       PACKAGES:=\
+               kmod-usb-core kmod-usb2 kmod-usb-ohci \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/mt7688/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,mt7688))