ramips: move different subtarget image generation to separate makefiles to improve...
[openwrt.git] / target / linux / ramips / image / mt7688.mk
diff --git a/target/linux/ramips/image/mt7688.mk b/target/linux/ramips/image/mt7688.mk
new file mode 100644 (file)
index 0000000..45991d0
--- /dev/null
@@ -0,0 +1,11 @@
+#
+# MT7688 Profiles
+#
+
+Image/Build/Profile/LinkIt7688=$(call BuildFirmware/Default32M/$(1),$(1),LinkIt7688,LINKIT7688)
+Image/Build/Profile/WRTNODE2R=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2r,WRTNODE2R)
+
+define Image/Build/Profile/Default
+       $(call Image/Build/Profile/LinkIt7688,$(1))
+       $(call Image/Build/Profile/WRTNODE2R,$(1))
+endef