oxnas: add patches and config for Linux 4.4
[openwrt.git] / target / linux / oxnas / patches-4.4 / 350-oxnas-reset.patch
diff --git a/target/linux/oxnas/patches-4.4/350-oxnas-reset.patch b/target/linux/oxnas/patches-4.4/350-oxnas-reset.patch
new file mode 100644 (file)
index 0000000..e9aaf4b
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/drivers/reset/Kconfig
++++ b/drivers/reset/Kconfig
+@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
+         If unsure, say no.
++config RESET_CONTROLLER_OXNAS
++      bool
++      select RESET_CONTROLLER
++
+ source "drivers/reset/sti/Kconfig"
++
+--- a/drivers/reset/Makefile
++++ b/drivers/reset/Makefile
+@@ -1,4 +1,5 @@
+ obj-$(CONFIG_RESET_CONTROLLER) += core.o
++obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
+ obj-$(CONFIG_ARCH_LPC18XX) += reset-lpc18xx.o
+ obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
+ obj-$(CONFIG_ARCH_BERLIN) += reset-berlin.o