mediatek: add support for the new MT7623 Arm SoC
[openwrt.git] / target / linux / mediatek / Makefile
diff --git a/target/linux/mediatek/Makefile b/target/linux/mediatek/Makefile
new file mode 100644 (file)
index 0000000..d0b266b
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright (c) 2015 OpenWrt.org
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mediatek
+BOARDNAME:=Mediatek Ralink ARM
+FEATURES:=squashfs
+CPU_TYPE:=cortex-a7
+MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+KERNEL_PATCHVER:=4.1
+
+KERNELNAME:=Image dtbs zImage
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
+$(eval $(call BuildTarget))