mcs814x: add 3.14 kernel support
[openwrt.git] / target / linux / mcs814x / patches-3.14 / 008-mcs814x_gpio.patch
diff --git a/target/linux/mcs814x/patches-3.14/008-mcs814x_gpio.patch b/target/linux/mcs814x/patches-3.14/008-mcs814x_gpio.patch
new file mode 100644 (file)
index 0000000..442ee1c
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -748,6 +748,12 @@ config GPIO_MC33880
+         SPI driver for Freescale MC33880 high-side/low-side switch.
+         This provides GPIO interface supporting inputs and outputs.
++config GPIO_MCS814X
++      tristate "Moschip MCS814x GPIO support"
++      depends on ARCH_MCS814X
++      help
++         GPIO driver for Moschip MCS814x SoC gpio controllers.
++
+ config GPIO_74X164
+       tristate "74x164 serial-in/parallel-out 8-bits shift register"
+       depends on SPI_MASTER && OF
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_GPIO_MAX732X)   += gpio-max73
+ obj-$(CONFIG_GPIO_MC33880)    += gpio-mc33880.o
+ obj-$(CONFIG_GPIO_MC9S08DZ60) += gpio-mc9s08dz60.o
+ obj-$(CONFIG_GPIO_MCP23S08)   += gpio-mcp23s08.o
++obj-$(CONFIG_GPIO_MCS814X)    += gpio-mcs814x.o
+ obj-$(CONFIG_GPIO_ML_IOH)     += gpio-ml-ioh.o
+ obj-$(CONFIG_GPIO_MM_LANTIQ)  += gpio-mm-lantiq.o
+ obj-$(CONFIG_GPIO_MOXART)     += gpio-moxart.o