malta: add le64 and be64 sub targets
[openwrt.git] / target / linux / malta / be64 / target.mk
diff --git a/target/linux/malta/be64/target.mk b/target/linux/malta/be64/target.mk
new file mode 100644 (file)
index 0000000..30804f4
--- /dev/null
@@ -0,0 +1,11 @@
+ARCH:=mips64
+ARCH_PACKAGES:=malta_mips64
+SUBTARGET:=be64
+BOARDNAME:=Big Endian (64-bits)
+CFLAGS:=-Os -pipe -mips64 -mtune=mips64 -fno-caller-saves
+FEATURES:=ramdisk
+
+define Target/Description
+       Build BE firmware images for MIPS Malta CoreLV board running in
+       big-endian and 64-bits mode
+endef