update lantiq/falcon patches
[openwrt.git] / target / linux / lantiq / patches-2.6.32 / 110-falcon_board.patch
index 9151463..db33d5a 100644 (file)
 +endif
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/Makefile
-@@ -0,0 +1,3 @@
+@@ -0,0 +1,4 @@
 +obj-y := clk-falcon.o devices.o gpio.o prom.o sysctrl.o reset.o
 +obj-y += softdog_vpe.o
++obj-$(CONFIG_LANTIQ_MACH_EASY98000) += addon-easy98000.o
 +obj-$(CONFIG_LANTIQ_MACH_EASY98000) += mach-easy98000.o
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/clk-falcon.c
@@ -71,7 +72,7 @@
 +EXPORT_SYMBOL(ltq_get_fpi_hz);
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/devices.c
-@@ -0,0 +1,180 @@
+@@ -0,0 +1,254 @@
 +#include <linux/init.h>
 +#include <linux/module.h>
 +#include <linux/types.h>
@@ -88,6 +89,7 @@
 +#include <linux/gpio.h>
 +#include <linux/leds.h>
 +#include <linux/spi/spi.h>
++#include <linux/mtd/nand.h>
 +
 +#include <asm/bootinfo.h>
 +#include <asm/irq.h>
@@ -96,6 +98,7 @@
 +
 +#include <falcon/falcon_irq.h>
 +#include <falcon/gpon_reg_base.h>
++#include <falcon/ebu_reg.h>
 +#include <falcon/sys1_reg.h>
 +#include <falcon/sys_eth_reg.h>
 +
 +      platform_device_register(&ltq_spi);
 +}
 +
++/* nand flash */
++static struct gpon_reg_ebu __iomem *membase_ebu;
++static const char *part_probes[] = { "cmdlinepart", NULL };
++
++static int falcon_nand_ready(struct mtd_info *mtd)
++{
++      u32 modcon = __raw_readl(&membase_ebu->modcon);
++
++      return (((modcon & (MODCON_STS|MODCON_STSEDGE)) ==
++                                              (MODCON_STS|MODCON_STSEDGE)));
++}
++
++/* address lines used for NAND control signals */
++#define NAND_ADDR_ALE         (1<<16)
++#define NAND_ADDR_CLE         (1<<17)
++
++static void falcon_hwcontrol(struct mtd_info *mtd, int cmd, unsigned int ctrl)
++{
++      struct nand_chip *this = mtd->priv;
++      unsigned long nandaddr = (unsigned long) this->IO_ADDR_W;
++
++      if (ctrl & NAND_CTRL_CHANGE) {
++              nandaddr &= ~(NAND_ADDR_ALE | NAND_ADDR_CLE);
++
++              if (ctrl & NAND_CLE)
++                      nandaddr |= NAND_ADDR_CLE;
++              if (ctrl & NAND_ALE)
++                      nandaddr |= NAND_ADDR_ALE;
++
++              this->IO_ADDR_W = (void __iomem *) nandaddr;
++      }
++
++      if (cmd != NAND_CMD_NONE)
++              writeb(cmd, this->IO_ADDR_W);
++}
++
++static struct platform_nand_data falcon_flash_nand_data = {
++      .chip = {
++              .nr_chips               = 1,
++              .chip_delay             = 25,
++              .part_probe_types       = part_probes,
++      },
++      .ctrl = {
++              .cmd_ctrl               = falcon_hwcontrol,
++              .dev_ready              = falcon_nand_ready,
++      }
++};
++
++static struct resource ltq_nand_resources[] = {
++      MEM_RES("nand", LTQ_FLASH_START, LTQ_FLASH_START + LTQ_FLASH_MAX - 1),
++      MEM_RES("ebu", GPON_EBU_BASE, GPON_EBU_END),
++};
++
++static struct platform_device ltq_flash_nand = {
++      .name           = "gen_nand",
++      .id             = -1,
++      .num_resources  = ARRAY_SIZE(ltq_nand_resources),
++      .resource       = ltq_nand_resources,
++      .dev            = {
++              .platform_data = &falcon_flash_nand_data,
++      },
++};
++
++void __init falcon_register_nand(void)
++{
++      membase_ebu = ioremap_nocache(ltq_nand_resources[1].start,
++                      resource_size(&ltq_nand_resources[1]));
++
++      if (membase_ebu)
++              platform_device_register(&ltq_flash_nand);
++}
++
 +/* watchdog */
 +static struct resource falcon_wdt_resource =
 +      MEM_RES("watchdog",GPON_WDT_BASE,GPON_WDT_END);
 +}
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/devices.h
-@@ -0,0 +1,21 @@
+@@ -0,0 +1,22 @@
 +#ifndef _FALCON_DEVICES_H__
 +#define _FALCON_DEVICES_H__
 +
 +extern void __init falcon_register_spi_flash(struct spi_board_info *data);
 +extern void __init falcon_register_gpio(void);
 +extern void __init falcon_register_nor(struct physmap_flash_data *data);
++extern void __init falcon_register_nand(void);
 +extern void __init falcon_register_wdt(void);
 +extern void __init falcon_register_crypto(void);
 +
 +}
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/sysctrl.c
-@@ -0,0 +1,381 @@
+@@ -0,0 +1,380 @@
 +/*
 + * This program is free software; you can redistribute it and/or
 + * modify it under the terms of the GNU General Public License as
 +              /* clock already active, no need to change here */
 +              return;
 +
-+      if (status_r32(config) == 0)
-+              aeFreq = 1; /* use 625MHz on unfused chip */
-+      else
-+              aeFreq = (status_r32(config) & STATUS_CONFIG_GPEFREQ_MASK) >> STATUS_CONFIG_GPEFREQ_OFFSET;
++      aeFreq = (status_r32(config) & STATUS_CONFIG_GPEFREQ_MASK) >> STATUS_CONFIG_GPEFREQ_OFFSET;
++      if (aeFreq == 0)
++              aeFreq = 1; /* use 625MHz on invalid value 0 */
 +      rd_data = sys1_r32(infrac);
 +      /* clear gpe-fsel and enable bits */
 +      rd_data_to_keep = rd_data & ~(7<<(INFRAC_GP_OFFSET+1));
 +#endif
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/reset.c
-@@ -0,0 +1,80 @@
+@@ -0,0 +1,65 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify
 + * it under the terms of the GNU General Public License as published by
 +
 +static struct gpon_reg_sys1 * const pSYS1 = (struct gpon_reg_sys1 *)GPON_SYS1_BASE;
 +
-+#define WDT_PW1                       0x00BE0000
-+#define WDT_PW2                       0x00DC0000
-+#define WDT_REG_BASE          (KSEG1 | 0x1F8803F0)
-+
 +/* This function is used by the watchdog driver */
 +int ltq_reset_cause(void)
 +{
 +      printk(KERN_NOTICE "System restart\n");
 +      local_irq_disable();
 +      ltq_w32(0, (void*)0xBF200000); /* reset Bootreg RVEC */
-+#if 0
 +      ltq_w32(RBT_CPU_TRIG, &pSYS1->rbt);
-+#else
-+      /* use workaround via watchdog timer */
-+      ltq_w32(WDT_PW1, (void*)WDT_REG_BASE);
-+      ltq_w32(WDT_PW2 |
-+              (0x3 << 26) | /* PWL */
-+              (0x2 << 24) | /* CLKDIV */
-+              (0x1 << 31) | /* enable */
-+              (1), /* reload */
-+              (void*)WDT_REG_BASE);
-+#endif
 +      for(;;);
 +}
 +
 +arch_initcall(mips_reboot_setup);
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/mach-easy98000.c
-@@ -0,0 +1,247 @@
+@@ -0,0 +1,263 @@
 +#include <linux/init.h>
 +#include <linux/platform_device.h>
 +#include <linux/leds.h>
 +      }
 +};
 +
++extern int easy98000_addon_has_dm9000(void);
 +static void __init register_davicom(void)
 +{
++      if (!easy98000_addon_has_dm9000())
++              return;
++
 +      if (!is_valid_ether_addr(ltq_ethaddr))
 +              random_ether_addr(dm9000_plat_data.dev_addr);
 +      else {
 +      }
 +};
 +
-+void __init register_easy98000_cpld_led(void)
++void __init register_easy98000_cpld(void)
 +{
 +      platform_device_register_simple("easy98000_cpld_led", 0, NULL, 0);
++      platform_device_register_simple("easy98000_addon", 0, NULL, 0);
 +}
 +
 +/* setup gpio based spi bus/device for access to the eeprom on the board */
 +      register_davicom();
 +      ltq_add_device_leds_gpio(-1, ARRAY_SIZE(easy98000_leds_gpio),
 +                                      easy98000_leds_gpio);
-+      register_easy98000_cpld_led();
++      register_easy98000_cpld();
 +      falcon_register_crypto();
 +      easy98000_spi_gpio_init();
 +}
 +      falcon_register_spi_flash(&easy98000_spi_flash_data);
 +}
 +
++static void __init easy98000nand_init(void)
++{
++      easy98000_init_common();
++      falcon_register_nand();
++}
++
 +MIPS_MACHINE(LANTIQ_MACH_EASY98000,
 +                      "EASY98000",
 +                      "EASY98000 Eval Board",
 +                      "EASY98000SF",
 +                      "EASY98000 Eval Board (Serial Flash)",
 +                      easy98000sf_init);
++
++MIPS_MACHINE(LANTIQ_MACH_EASY98000NAND,
++                      "EASY98000NAND",
++                      "EASY98000 Eval Board (NAND Flash)",
++                      easy98000nand_init);
 --- /dev/null
 +++ b/arch/mips/lantiq/falcon/softdog_vpe.c
 @@ -0,0 +1,109 @@
 +#endif
 --- a/arch/mips/lantiq/Kconfig
 +++ b/arch/mips/lantiq/Kconfig
-@@ -16,8 +16,12 @@
+@@ -16,8 +16,12 @@ config SOC_XWAY
        bool "XWAY"
        select SOC_TYPE_XWAY
        select HW_HAS_PCI
  endif
 --- a/arch/mips/lantiq/Makefile
 +++ b/arch/mips/lantiq/Makefile
-@@ -9,3 +9,4 @@
+@@ -9,3 +9,4 @@ obj-y := irq.o setup.o clk.o prom.o devi
  obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
  
  obj-$(CONFIG_SOC_TYPE_XWAY) += xway/
 +obj-$(CONFIG_SOC_FALCON) += falcon/
 --- a/arch/mips/lantiq/Platform
 +++ b/arch/mips/lantiq/Platform
-@@ -6,3 +6,4 @@
+@@ -6,3 +6,4 @@ platform-$(CONFIG_LANTIQ)      += lantiq/
  cflags-$(CONFIG_LANTIQ)               += -I$(srctree)/arch/mips/include/asm/mach-lantiq
  load-$(CONFIG_LANTIQ)         = 0xffffffff80002000
  cflags-$(CONFIG_SOC_TYPE_XWAY)        += -I$(srctree)/arch/mips/include/asm/mach-lantiq/xway
 +cflags-$(CONFIG_SOC_FALCON)   += -I$(srctree)/arch/mips/include/asm/mach-lantiq/falcon
 --- a/arch/mips/lantiq/machtypes.h
 +++ b/arch/mips/lantiq/machtypes.h
-@@ -15,6 +15,11 @@
+@@ -15,6 +15,12 @@ enum lantiq_mach_type {
        LTQ_MACH_GENERIC = 0,
        LTQ_MACH_EASY50712,     /* Danube evaluation board */
        LTQ_MACH_EASY50601,     /* Amazon SE evaluation board */
 +      /* FALCON */
 +      LANTIQ_MACH_EASY98000,          /* Falcon Eval Board, NOR Flash */
 +      LANTIQ_MACH_EASY98000SF,        /* Falcon Eval Board, Serial Flash */
++      LANTIQ_MACH_EASY98000NAND,      /* Falcon Eval Board, NAND Flash */
 +      LANTIQ_MACH_EASY98020,          /* Falcon Reference Board */
  };
  
  #endif
+--- /dev/null
++++ b/arch/mips/lantiq/falcon/addon-easy98000.c
+@@ -0,0 +1,212 @@
++/*
++ *  EASY98000 CPLD Addon driver
++ *
++ *  Copyright (C) 2011 Thomas Langer <thomas.langer@lantiq.com>
++ *
++ *  This program is free software; you can redistribute it and/or modify it
++ *  under the terms of the GNU General Public License version 2  as published
++ *  by the Free Software Foundation.
++ *
++ */
++
++#include <linux/kernel.h>
++#include <linux/version.h>
++#include <linux/types.h>
++#include <linux/init.h>
++#include <linux/platform_device.h>
++#include <linux/errno.h>
++#include <linux/slab.h>
++#include <linux/proc_fs.h>
++#include <linux/seq_file.h>
++
++struct easy98000_reg_cpld {
++      u16 cmdreg1;            /* 0x1 */
++      u16 cmdreg0;            /* 0x0 */
++      u16 idreg0;             /* 0x3 */
++      u16 resreg;             /* 0x2 */
++      u16 intreg;             /* 0x5 */
++      u16 idreg1;             /* 0x4 */
++      u16 ledreg;             /* 0x7 */
++      u16 pcmconconfig;       /* 0x6 */
++      u16 res0;               /* 0x9 */
++      u16 ethledreg;          /* 0x8 */
++      u16 res1[4];            /* 0xa-0xd */
++      u16 cpld1v;             /* 0xf */
++      u16 cpld2v;             /* 0xe */
++};
++static struct easy98000_reg_cpld * const cpld =
++      (struct easy98000_reg_cpld *)(KSEG1 | 0x17c00000);
++#define cpld_r8(reg) (__raw_readw(&cpld->reg) & 0xFF)
++#define cpld_w8(val, reg) __raw_writew((val) & 0xFF, &cpld->reg)
++
++int easy98000_addon_has_dm9000(void)
++{
++      if ((cpld_r8(idreg0) & 0xF) == 1)
++              return 1;
++      return 0;
++}
++
++#if defined(CONFIG_PROC_FS)
++typedef void (*cpld_dump) (struct seq_file *s);
++struct proc_entry {
++      char *name;
++      void *callback;
++};
++
++static int cpld_proc_show ( struct seq_file *s, void *p )
++{
++      cpld_dump dump = s->private;
++
++      if ( dump != NULL )
++              dump(s);
++
++      return 0;
++}
++
++static int cpld_proc_open ( struct inode *inode, struct file *file )
++{
++      return single_open ( file, cpld_proc_show, PDE(inode)->data );
++}
++
++static void cpld_versions_get ( struct seq_file *s )
++{
++      seq_printf(s, "CPLD1: V%d\n", cpld_r8(cpld1v));
++      seq_printf(s, "CPLD2: V%d\n", cpld_r8(cpld2v));
++}
++
++static void cpld_ebu_module_get ( struct seq_file *s )
++{
++      u8 addon_id;
++
++      addon_id = cpld_r8(idreg0) & 0xF;
++      switch (addon_id) {
++      case 0xF: /* nothing connected */
++              break;
++      case 1:
++              seq_printf(s, "Ethernet Controller module (dm9000)\n");
++              break;
++      default:
++              seq_printf(s, "Unknown EBU module (EBU_ID=0x%02X)\n", addon_id);
++              break;
++      }
++}
++
++static void cpld_xmii_module_get ( struct seq_file *s )
++{
++      u8 addon_id;
++      char *mod = NULL;
++
++      addon_id = cpld_r8(idreg1) & 0xF;
++      switch (addon_id) {
++      case 0xF:
++              mod = "no module";
++              break;
++      case 0x1:
++              mod = "RGMII module";
++              break;
++      case 0x4:
++              mod = "GMII MAC Mode (XWAY TANTOS-3G)";
++              break;
++      case 0x6:
++              mod = "TMII MAC Mode (XWAY TANTOS-3G)";
++              break;
++      case 0x8:
++              mod = "GMII PHY module";
++              break;
++      case 0x9:
++              mod = "MII PHY module";
++              break;
++      case 0xA:
++              mod = "RMII PHY module";
++              break;
++      default:
++              break;
++      }
++      if (mod)
++              seq_printf(s, "%s\n", mod);
++      else
++              seq_printf(s, "unknown xMII module (xMII_ID=0x%02X)\n", addon_id);
++}
++
++static struct proc_entry proc_entries[] = {
++      {"versions",    cpld_versions_get},
++      {"ebu",         cpld_ebu_module_get},
++      {"xmii",        cpld_xmii_module_get},
++};
++
++static struct file_operations ops = {
++      .owner   = THIS_MODULE,
++      .open    = cpld_proc_open,
++      .read    = seq_read,
++      .llseek  = seq_lseek,
++      .release = single_release,
++};
++
++static void cpld_proc_entry_create(struct proc_dir_entry *parent_node,
++                                 struct proc_entry *proc_entry)
++{
++      proc_create_data ( proc_entry->name, (S_IFREG | S_IRUGO), parent_node,
++                         &ops, proc_entry->callback);
++}
++
++static int cpld_proc_install(void)
++{
++      struct proc_dir_entry *driver_proc_node;
++
++      driver_proc_node = proc_mkdir("cpld", NULL);
++      if (driver_proc_node != NULL) {
++              int i;
++              for (i = 0; i < ARRAY_SIZE(proc_entries); i++)
++                      cpld_proc_entry_create(driver_proc_node,
++                                            &proc_entries[i]);
++      } else {
++              printk("cannot create proc entry");
++              return -1;
++      }
++      return 0;
++}
++#else
++static inline int cpld_proc_install(void) {}
++#endif
++
++static int easy98000_addon_probe(struct platform_device *pdev)
++{
++      return cpld_proc_install();
++}
++
++static int easy98000_addon_remove(struct platform_device *pdev)
++{
++#if defined(CONFIG_PROC_FS)
++      char buf[64];
++      int i;
++
++      for (i = 0; i < sizeof(proc_entries) / sizeof(proc_entries[0]); i++) {
++              sprintf(buf, "cpld/%s", proc_entries[i].name);
++              remove_proc_entry(buf, 0);
++      }
++      remove_proc_entry("cpld", 0);
++#endif
++      return 0;
++}
++
++static struct platform_driver easy98000_addon_driver = {
++      .probe = easy98000_addon_probe,
++      .remove = __devexit_p(easy98000_addon_remove),
++      .driver = {
++              .name = "easy98000_addon",
++              .owner = THIS_MODULE,
++      },
++};
++
++int __init easy98000_addon_init(void)
++{
++      return platform_driver_register(&easy98000_addon_driver);
++}
++
++void __exit easy98000_addon_exit(void)
++{
++      platform_driver_unregister(&easy98000_addon_driver);
++}
++
++module_init(easy98000_addon_init);
++module_exit(easy98000_addon_exit);