ixp4xx: remove linux 3.10 support
[openwrt.git] / target / linux / ixp4xx / patches-3.10 / 130-wrt300nv2_support.patch
diff --git a/target/linux/ixp4xx/patches-3.10/130-wrt300nv2_support.patch b/target/linux/ixp4xx/patches-3.10/130-wrt300nv2_support.patch
deleted file mode 100644 (file)
index 8692b34..0000000
+++ /dev/null
@@ -1,227 +0,0 @@
---- a/arch/arm/mach-ixp4xx/Kconfig
-+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -97,6 +97,14 @@ config MACH_COMPEXWP18
-         WP18 or NP18A boards. For more information on this
-         platform, see http://www.compex.com.sg/home/OEM/product_ap.htm
-+config MACH_WRT300NV2
-+      bool "Linksys WRT300N v2"
-+      select PCI
-+      help
-+        Say 'Y' here if you want your kernel to support Linksys'
-+        WRT300N v2 router. For more information on this
-+        platform, see http://openwrt.org
-+
- config ARCH_IXDP425
-       bool "IXDP425"
-       help
---- a/arch/arm/mach-ixp4xx/Makefile
-+++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -22,6 +22,7 @@ obj-pci-$(CONFIG_MACH_ARCOM_VULCAN)  += v
- obj-pci-$(CONFIG_MACH_PRONGHORN)      += pronghorn-pci.o
- obj-pci-$(CONFIG_MACH_SIDEWINDER)     += sidewinder-pci.o
- obj-pci-$(CONFIG_MACH_COMPEXWP18)     += ixdp425-pci.o
-+obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
- obj-y += common.o
-@@ -45,6 +46,7 @@ obj-$(CONFIG_MACH_ARCOM_VULCAN)      += vulca
- obj-$(CONFIG_MACH_PRONGHORN)  += pronghorn-setup.o
- obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
- obj-$(CONFIG_MACH_COMPEXWP18) += compex42x-setup.o
-+obj-$(CONFIG_MACH_WRT300NV2)  += wrt300nv2-setup.o
- obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
- obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
---- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
-+++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
-@@ -43,7 +43,8 @@ static __inline__ void __arch_decomp_set
-       if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
-           machine_is_gateway7001() || machine_is_wg302v2() ||
-           machine_is_devixp() || machine_is_miccpt() || machine_is_mic256() ||
--          machine_is_pronghorn() || machine_is_pronghorn_metro())
-+          machine_is_pronghorn() || machine_is_pronghorn_metro() ||
-+          machine_is_wrt300nv2())
-               uart_base = (volatile u32*) IXP4XX_UART2_BASE_PHYS;
-       else
-               uart_base = (volatile u32*) IXP4XX_UART1_BASE_PHYS;
---- /dev/null
-+++ b/arch/arm/mach-ixp4xx/wrt300nv2-pci.c
-@@ -0,0 +1,64 @@
-+/*
-+ * arch/arch/mach-ixp4xx/wrt300nv2-pci.c
-+ *
-+ * PCI setup routines for Linksys WRT300N v2
-+ *
-+ * Copyright (C) 2007 Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * based on coyote-pci.c:
-+ *    Copyright (C) 2002 Jungo Software Technologies.
-+ *    Copyright (C) 2003 MontaVista Softwrae, Inc.
-+ *
-+ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License version 2 as
-+ * published by the Free Software Foundation.
-+ *
-+ */
-+
-+#include <linux/kernel.h>
-+#include <linux/pci.h>
-+#include <linux/init.h>
-+#include <linux/irq.h>
-+
-+#include <asm/mach-types.h>
-+#include <mach/hardware.h>
-+#include <asm/irq.h>
-+
-+#include <asm/mach/pci.h>
-+
-+extern void ixp4xx_pci_preinit(void);
-+extern int ixp4xx_setup(int nr, struct pci_sys_data *sys);
-+extern struct pci_bus *ixp4xx_scan_bus(int nr, struct pci_sys_data *sys);
-+
-+void __init wrt300nv2_pci_preinit(void)
-+{
-+      irq_set_irq_type(IRQ_IXP4XX_GPIO8, IRQ_TYPE_LEVEL_LOW);
-+
-+      ixp4xx_pci_preinit();
-+}
-+
-+static int __init wrt300nv2_map_irq(const struct pci_dev *dev, u8 slot, u8 pin)
-+{
-+      if (slot == 1)
-+              return IRQ_IXP4XX_GPIO8;
-+      else return -1;
-+}
-+
-+struct hw_pci wrt300nv2_pci __initdata = {
-+      .nr_controllers = 1,
-+      .preinit        = wrt300nv2_pci_preinit,
-+      .ops            = &ixp4xx_ops,
-+      .setup          = ixp4xx_setup,
-+      .map_irq        = wrt300nv2_map_irq,
-+};
-+
-+int __init wrt300nv2_pci_init(void)
-+{
-+      if (machine_is_wrt300nv2())
-+              pci_common_init(&wrt300nv2_pci);
-+      return 0;
-+}
-+
-+subsys_initcall(wrt300nv2_pci_init);
---- /dev/null
-+++ b/arch/arm/mach-ixp4xx/wrt300nv2-setup.c
-@@ -0,0 +1,110 @@
-+/*
-+ * arch/arm/mach-ixp4xx/wrt300nv2-setup.c
-+ *
-+ * Board setup for the Linksys WRT300N v2
-+ *
-+ * Copyright (C) 2007 Imre Kaloz <Kaloz@openwrt.org>
-+ *
-+ * based on coyote-setup.c:
-+ *      Copyright (C) 2003-2005 MontaVista Software, Inc.
-+ *
-+ * Author: Imre Kaloz <Kaloz@openwrt.org>
-+ */
-+
-+#include <linux/kernel.h>
-+#include <linux/init.h>
-+#include <linux/device.h>
-+#include <linux/serial.h>
-+#include <linux/tty.h>
-+#include <linux/serial_8250.h>
-+#include <linux/slab.h>
-+
-+#include <asm/types.h>
-+#include <asm/setup.h>
-+#include <asm/memory.h>
-+#include <mach/hardware.h>
-+#include <asm/irq.h>
-+#include <asm/mach-types.h>
-+#include <asm/mach/arch.h>
-+#include <asm/mach/flash.h>
-+
-+static struct flash_platform_data wrt300nv2_flash_data = {
-+      .map_name       = "cfi_probe",
-+      .width          = 2,
-+};
-+
-+static struct resource wrt300nv2_flash_resource = {
-+      .flags          = IORESOURCE_MEM,
-+};
-+
-+static struct platform_device wrt300nv2_flash = {
-+      .name           = "IXP4XX-Flash",
-+      .id             = 0,
-+      .dev            = {
-+              .platform_data = &wrt300nv2_flash_data,
-+      },
-+      .num_resources  = 1,
-+      .resource       = &wrt300nv2_flash_resource,
-+};
-+
-+static struct resource wrt300nv2_uart_resource = {
-+      .start  = IXP4XX_UART2_BASE_PHYS,
-+      .end    = IXP4XX_UART2_BASE_PHYS + 0x0fff,
-+      .flags  = IORESOURCE_MEM,
-+};
-+
-+static struct plat_serial8250_port wrt300nv2_uart_data[] = {
-+      {
-+              .mapbase        = IXP4XX_UART2_BASE_PHYS,
-+              .membase        = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
-+              .irq            = IRQ_IXP4XX_UART2,
-+              .flags          = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
-+              .iotype         = UPIO_MEM,
-+              .regshift       = 2,
-+              .uartclk        = IXP4XX_UART_XTAL,
-+      },
-+      { },
-+};
-+
-+static struct platform_device wrt300nv2_uart = {
-+      .name           = "serial8250",
-+      .id             = PLAT8250_DEV_PLATFORM,
-+      .dev                    = {
-+              .platform_data  = wrt300nv2_uart_data,
-+      },
-+      .num_resources  = 1,
-+      .resource       = &wrt300nv2_uart_resource,
-+};
-+
-+static struct platform_device *wrt300nv2_devices[] __initdata = {
-+      &wrt300nv2_flash,
-+      &wrt300nv2_uart
-+};
-+
-+static void __init wrt300nv2_init(void)
-+{
-+      ixp4xx_sys_init();
-+
-+      wrt300nv2_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
-+      wrt300nv2_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_32M - 1;
-+
-+      *IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
-+      *IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
-+
-+      platform_add_devices(wrt300nv2_devices, ARRAY_SIZE(wrt300nv2_devices));
-+}
-+
-+#ifdef CONFIG_MACH_WRT300NV2
-+MACHINE_START(WRT300NV2, "Linksys WRT300N v2")
-+      /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
-+      .map_io         = ixp4xx_map_io,
-+      .init_irq       = ixp4xx_init_irq,
-+      .init_time      = ixp4xx_timer_init,
-+      .atag_offset    = 0x0100,
-+      .init_machine   = wrt300nv2_init,
-+#if defined(CONFIG_PCI)
-+      .dma_zone_size  = SZ_64M,
-+#endif
-+      .restart        = ixp4xx_restart,
-+MACHINE_END
-+#endif