kernel: update 3.14 to 3.14.18
[openwrt.git] / target / linux / ipq806x / patches / 0004-clocksource-qcom-Move-clocksource-code-out-of-mach-m.patch
index fd730c1..c726d3f 100644 (file)
@@ -20,8 +20,6 @@ Signed-off-by: Kumar Gala <galak@codeaurora.org>
  delete mode 100644 arch/arm/mach-msm/timer.c
  create mode 100644 drivers/clocksource/qcom-timer.c
 
-diff --git a/arch/arm/mach-msm/Kconfig b/arch/arm/mach-msm/Kconfig
-index 9625cf3..3c4eca7 100644
 --- a/arch/arm/mach-msm/Kconfig
 +++ b/arch/arm/mach-msm/Kconfig
 @@ -21,7 +21,7 @@ config ARCH_MSM8X60
@@ -77,8 +75,6 @@ index 9625cf3..3c4eca7 100644
 -      bool
 -
  endif
-diff --git a/arch/arm/mach-msm/Makefile b/arch/arm/mach-msm/Makefile
-index 8327f60..04b1bee 100644
 --- a/arch/arm/mach-msm/Makefile
 +++ b/arch/arm/mach-msm/Makefile
 @@ -1,4 +1,3 @@
@@ -86,9 +82,6 @@ index 8327f60..04b1bee 100644
  obj-$(CONFIG_MSM_PROC_COMM) += clock.o
  
  obj-$(CONFIG_MSM_VIC) += irq-vic.o
-diff --git a/arch/arm/mach-msm/timer.c b/arch/arm/mach-msm/timer.c
-deleted file mode 100644
-index fd16449..0000000
 --- a/arch/arm/mach-msm/timer.c
 +++ /dev/null
 @@ -1,333 +0,0 @@
@@ -425,8 +418,6 @@ index fd16449..0000000
 -              return;
 -      msm_timer_init(19200000 / 4, 32, 7, false);
 -}
-diff --git a/drivers/clocksource/Kconfig b/drivers/clocksource/Kconfig
-index cd6950f..6510ec4 100644
 --- a/drivers/clocksource/Kconfig
 +++ b/drivers/clocksource/Kconfig
 @@ -140,3 +140,6 @@ config VF_PIT_TIMER
@@ -436,11 +427,9 @@ index cd6950f..6510ec4 100644
 +
 +config CLKSRC_QCOM
 +      bool
-diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
-index c7ca50a..2e0c0cc 100644
 --- a/drivers/clocksource/Makefile
 +++ b/drivers/clocksource/Makefile
-@@ -32,6 +32,7 @@ obj-$(CONFIG_CLKSRC_EFM32)   += time-efm32.o
+@@ -32,6 +32,7 @@ obj-$(CONFIG_CLKSRC_EFM32)   += time-efm32
  obj-$(CONFIG_CLKSRC_EXYNOS_MCT)       += exynos_mct.o
  obj-$(CONFIG_CLKSRC_SAMSUNG_PWM)      += samsung_pwm_timer.o
  obj-$(CONFIG_VF_PIT_TIMER)    += vf_pit_timer.o
@@ -448,9 +437,6 @@ index c7ca50a..2e0c0cc 100644
  
  obj-$(CONFIG_ARM_ARCH_TIMER)          += arm_arch_timer.o
  obj-$(CONFIG_ARM_GLOBAL_TIMER)                += arm_global_timer.o
-diff --git a/drivers/clocksource/qcom-timer.c b/drivers/clocksource/qcom-timer.c
-new file mode 100644
-index 0000000..dca829e
 --- /dev/null
 +++ b/drivers/clocksource/qcom-timer.c
 @@ -0,0 +1,329 @@
@@ -783,6 +769,3 @@ index 0000000..dca829e
 +              return;
 +      msm_timer_init(19200000 / 4, 32, 7, false);
 +}
--- 
-1.7.10.4
-