kernel: generic: add kernel 4.3
[openwrt.git] / target / linux / generic / patches-4.3 / 725-phy_rtl8306.patch
diff --git a/target/linux/generic/patches-4.3/725-phy_rtl8306.patch b/target/linux/generic/patches-4.3/725-phy_rtl8306.patch
new file mode 100644 (file)
index 0000000..803e770
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -166,6 +166,10 @@ config AR8216_PHY
+       select ETHERNET_PACKET_MANGLE
+       select SWCONFIG
++config RTL8306_PHY
++      tristate "Driver for Realtek RTL8306S switches"
++      select SWCONFIG
++
+ config FIXED_PHY
+       tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -25,6 +25,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_AR8216_PHY)      += ar8216.o ar8327.o
++obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o