generic: drop 3.14
[openwrt.git] / target / linux / generic / patches-3.14 / 304-mips_disable_fpu.patch
diff --git a/target/linux/generic/patches-3.14/304-mips_disable_fpu.patch b/target/linux/generic/patches-3.14/304-mips_disable_fpu.patch
deleted file mode 100644 (file)
index adc9346..0000000
+++ /dev/null
@@ -1,160 +0,0 @@
-MIPS: allow disabling the kernel FPU emulator
-
-This patch allows turning off the in-kernel Algorithmics
-FPU emulator support, which allows one to save a couple of
-precious blocks on an embedded system.
-
-Signed-off-by: Florian Fainelli <florian@openwrt.org>
---
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -935,6 +935,17 @@ config I8259
- config MIPS_BONITO64
-       bool
-+config MIPS_FPU_EMU
-+      bool "Enable FPU emulation"
-+      default y
-+      help
-+         This option allows building a kernel with or without the Algorithmics
-+         FPU emulator enabled. Turning off this option results in a kernel which
-+         does not catch floating operations exceptions. Make sure that your toolchain
-+         is configured to enable software floating point emulation in that case.
-+
-+         If unsure say Y here.
-+
- config MIPS_MSC
-       bool
---- a/arch/mips/math-emu/Makefile
-+++ b/arch/mips/math-emu/Makefile
-@@ -2,10 +2,12 @@
- # Makefile for the Linux/MIPS kernel FPU emulation.
- #
--obj-y := cp1emu.o ieee754m.o ieee754d.o ieee754dp.o ieee754sp.o ieee754.o \
-+obj-y := kernel_linkage.o
-+
-+obj-$(CONFIG_MIPS_FPU_EMU)    += ieee754m.o ieee754d.o ieee754dp.o ieee754sp.o ieee754.o \
-          ieee754xcpt.o dp_frexp.o dp_modf.o dp_div.o dp_mul.o dp_sub.o \
-          dp_add.o dp_fsp.o dp_cmp.o dp_logb.o dp_scalb.o dp_simple.o \
-          dp_tint.o dp_fint.o dp_tlong.o dp_flong.o sp_frexp.o sp_modf.o \
-          sp_div.o sp_mul.o sp_sub.o sp_add.o sp_fdp.o sp_cmp.o sp_logb.o \
-          sp_scalb.o sp_simple.o sp_tint.o sp_fint.o sp_tlong.o sp_flong.o \
--         dp_sqrt.o sp_sqrt.o kernel_linkage.o dsemul.o
-+         dp_sqrt.o sp_sqrt.o dsemul.o cp1emu.o
---- a/arch/mips/math-emu/kernel_linkage.c
-+++ b/arch/mips/math-emu/kernel_linkage.c
-@@ -29,6 +29,7 @@
- #define SIGNALLING_NAN 0x7ff800007ff80000LL
-+#ifdef CONFIG_MIPS_FPU_EMU
- void fpu_emulator_init_fpu(void)
- {
-       static int first = 1;
-@@ -115,3 +116,36 @@ int fpu_emulator_restore_context32(struc
-       return err;
- }
- #endif
-+
-+#else
-+
-+void fpu_emulator_init_fpu(void)
-+{
-+      printk(KERN_INFO "FPU emulator disabled, make sure your toolchain"
-+              "was compiled with software floating point support (soft-float)\n");
-+      return;
-+}
-+
-+int fpu_emulator_save_context(struct sigcontext __user *sc)
-+{
-+      return 0;
-+}
-+
-+int fpu_emulator_restore_context(struct sigcontext __user *sc)
-+{
-+      return 0;
-+}
-+
-+#ifdef CONFIG_64BIT
-+int fpu_emulator_save_context32(struct sigcontext32 __user *sc)
-+{
-+      return 0;
-+}
-+
-+int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
-+{
-+      return 0;
-+}
-+#endif /* CONFIG_64BIT */
-+
-+#endif /* CONFIG_MIPS_FPU_EMU */
---- a/arch/mips/include/asm/fpu_emulator.h
-+++ b/arch/mips/include/asm/fpu_emulator.h
-@@ -27,6 +27,8 @@
- #include <asm/inst.h>
- #include <asm/local.h>
-+#ifdef CONFIG_MIPS_FPU_EMU
-+
- #ifdef CONFIG_DEBUG_FS
- struct mips_fpu_emulator_stats {
-@@ -60,6 +62,38 @@ extern int fpu_emulator_cop1Handler(stru
- int process_fpemu_return(int sig, void __user *fault_addr);
- int mm_isBranchInstr(struct pt_regs *regs, struct mm_decoded_insn dec_insn,
-                    unsigned long *contpc);
-+#else
-+static inline int mips_dsemul(struct pt_regs *regs, mips_instruction ir,
-+                            unsigned long cpc)
-+{
-+      return 0;
-+}
-+
-+static inline int do_dsemulret(struct pt_regs *xcp)
-+{
-+      return 0;
-+}
-+
-+static inline int fpu_emulator_cop1Handler(struct pt_regs *xcp,
-+                                         struct mips_fpu_struct *ctx,
-+                                         int has_fpu,
-+                                         void *__user *fault_addr)
-+{
-+      return 0;
-+}
-+
-+static inline int process_fpemu_return(int sig, void __user *fault_addr)
-+{
-+      return -EINVAL;
-+}
-+
-+static inline int mm_isBranchInstr(struct pt_regs *regs,
-+                                 struct mm_decoded_insn dec_insn,
-+                                 unsigned long *contpc)
-+{
-+      return 0;
-+}
-+#endif /* CONFIG_MIPS_FPU_EMU */
- /*
-  * Instruction inserted following the badinst to further tag the sequence
---- a/arch/mips/kernel/traps.c
-+++ b/arch/mips/kernel/traps.c
-@@ -701,6 +701,7 @@ asmlinkage void do_ov(struct pt_regs *re
-       exception_exit(prev_state);
- }
-+#ifdef CONFIG_MIPS_FPU_EMU
- int process_fpemu_return(int sig, void __user *fault_addr)
- {
-       if (sig == SIGSEGV || sig == SIGBUS) {
-@@ -724,6 +725,7 @@ int process_fpemu_return(int sig, void _
-               return 0;
-       }
- }
-+#endif /* CONFIG_MIPS_FPU_EMU */
- /*
-  * XXX Delayed fp exceptions when doing a lazy ctx switch XXX