kernel: refresh patches
[openwrt.git] / target / linux / brcm2708 / patches-3.14 / 0038-ASoC-Add-support-for-HifiBerry-DAC.patch
index d3c1a9c..1aba4c2 100644 (file)
@@ -15,8 +15,6 @@ Signed-off-by: Florian Meier <florian.meier@koalo.de>
  3 files changed, 112 insertions(+)
  create mode 100644 sound/soc/bcm/hifiberry_dac.c
 
-diff --git a/sound/soc/bcm/Kconfig b/sound/soc/bcm/Kconfig
-index 7e5b945..b36a62f 100644
 --- a/sound/soc/bcm/Kconfig
 +++ b/sound/soc/bcm/Kconfig
 @@ -18,3 +18,10 @@ config SND_BCM2708_SOC_I2S
@@ -30,11 +28,9 @@ index 7e5b945..b36a62f 100644
 +        select SND_SOC_PCM5102A
 +        help
 +         Say Y or M if you want to add support for HifiBerry DAC.
-diff --git a/sound/soc/bcm/Makefile b/sound/soc/bcm/Makefile
-index f8bbe1f..be90a49cb 100644
 --- a/sound/soc/bcm/Makefile
 +++ b/sound/soc/bcm/Makefile
-@@ -7,3 +7,8 @@ obj-$(CONFIG_SND_BCM2835_SOC_I2S) += snd-soc-bcm2835-i2s.o
+@@ -7,3 +7,8 @@ obj-$(CONFIG_SND_BCM2835_SOC_I2S) += snd
  snd-soc-bcm2708-i2s-objs := bcm2708-i2s.o
  
  obj-$(CONFIG_SND_BCM2708_SOC_I2S) += snd-soc-bcm2708-i2s.o
@@ -43,9 +39,6 @@ index f8bbe1f..be90a49cb 100644
 +snd-soc-hifiberry-dac-objs := hifiberry_dac.o
 +
 +obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
-diff --git a/sound/soc/bcm/hifiberry_dac.c b/sound/soc/bcm/hifiberry_dac.c
-new file mode 100644
-index 0000000..4b70b45
 --- /dev/null
 +++ b/sound/soc/bcm/hifiberry_dac.c
 @@ -0,0 +1,100 @@
@@ -149,6 +142,3 @@ index 0000000..4b70b45
 +MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
 +MODULE_DESCRIPTION("ASoC Driver for HifiBerry DAC");
 +MODULE_LICENSE("GPL v2");
--- 
-1.9.1
-