brcm2708: add Raspberry Pi 3 support
[openwrt.git] / target / linux / brcm2708 / image / Makefile
index f96dccb..8cf83a4 100644 (file)
@@ -57,7 +57,7 @@ DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
 # $(1) = profile
 # $(2) = image name
 # $(3) = dts
-define bcm270x
+define bcm27xx
   define Device/$(2)
     DEVICE_PROFILE := $(1)
     DEVICE_DTS := $(3)
@@ -68,13 +68,19 @@ endef
 ### BCM2708/BCM2835 ###
 ifeq ($(SUBTARGET),bcm2708)
   # Raspberry Pi Models B/B+/CM
-  $(eval $(call bcm270x,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
+  $(eval $(call bcm27xx,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
 endif
 
 ### BCM2709/BCM2836 ###
 ifeq ($(SUBTARGET),bcm2709)
   # Raspberry Pi 2 Model B
-  $(eval $(call bcm270x,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+  $(eval $(call bcm27xx,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+endif
+
+### BCM2710/BCM2837 ###
+ifeq ($(SUBTARGET),bcm2710)
+  # Raspberry Pi 3 Model B
+  $(eval $(call bcm27xx,RaspberryPi_3,rpi-3,bcm2710-rpi-3-b))
 endif
 
 $(eval $(call BuildImage))