ar71xx: remove 3.6 support
[openwrt.git] / target / linux / ar71xx / patches-3.6 / 602-MIPS-ath79-add-openwrt-stuff.patch
diff --git a/target/linux/ar71xx/patches-3.6/602-MIPS-ath79-add-openwrt-stuff.patch b/target/linux/ar71xx/patches-3.6/602-MIPS-ath79-add-openwrt-stuff.patch
deleted file mode 100644 (file)
index da284e2..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -106,6 +106,20 @@ config SOC_QCA955X
-       select PCI_AR724X if PCI
-       def_bool n
-+config ATH79_DEV_M25P80
-+      select ATH79_DEV_SPI
-+      def_bool n
-+
-+config ATH79_DEV_AP9X_PCI
-+      select ATH79_PCI_ATH9K_FIXUP
-+      def_bool n
-+
-+config ATH79_DEV_DSA
-+      def_bool n
-+
-+config ATH79_DEV_ETH
-+      def_bool n
-+
- config PCI_AR724X
-       def_bool n
-@@ -115,6 +129,10 @@ config ATH79_DEV_GPIO_BUTTONS
- config ATH79_DEV_LEDS_GPIO
-       def_bool n
-+config ATH79_DEV_NFC
-+      depends on (SOC_AR934X || SOC_QCA955X)
-+      def_bool n
-+
- config ATH79_DEV_SPI
-       def_bool n
-@@ -125,4 +143,13 @@ config ATH79_DEV_WMAC
-       depends on (SOC_AR913X || SOC_AR933X || SOC_AR934X || SOC_QCA955X)
-       def_bool n
-+config ATH79_NVRAM
-+      def_bool n
-+
-+config ATH79_PCI_ATH9K_FIXUP
-+      def_bool n
-+
-+config ATH79_ROUTERBOOT
-+      def_bool n
-+
- endif
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -17,13 +17,25 @@ obj-$(CONFIG_PCI)                  += pci.o
- # Devices
- #
- obj-y                                 += dev-common.o
-+obj-$(CONFIG_ATH79_DEV_AP9X_PCI)      += dev-ap9x-pci.o
-+obj-$(CONFIG_ATH79_DEV_DSA)           += dev-dsa.o
-+obj-$(CONFIG_ATH79_DEV_ETH)           += dev-eth.o
- obj-$(CONFIG_ATH79_DEV_GPIO_BUTTONS)  += dev-gpio-buttons.o
- obj-$(CONFIG_ATH79_DEV_LEDS_GPIO)     += dev-leds-gpio.o
-+obj-$(CONFIG_ATH79_DEV_M25P80)                += dev-m25p80.o
-+obj-$(CONFIG_ATH79_DEV_NFC)           += dev-nfc.o
- obj-$(CONFIG_ATH79_DEV_SPI)           += dev-spi.o
- obj-$(CONFIG_ATH79_DEV_USB)           += dev-usb.o
- obj-$(CONFIG_ATH79_DEV_WMAC)          += dev-wmac.o
- #
-+# Miscellaneous objects
-+#
-+obj-$(CONFIG_ATH79_NVRAM)             += nvram.o
-+obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP)   += pci-ath9k-fixup.o
-+obj-$(CONFIG_ATH79_ROUTERBOOT)                += routerboot.o
-+
-+#
- # Machines
- #
- obj-$(CONFIG_ATH79_MACH_AP121)                += mach-ap121.o