ar71xx: Add Support for the Bitmain Antminer S3
[openwrt.git] / target / linux / ar71xx / generic / profiles / antminer.mk
index 366982c..404133b 100644 (file)
@@ -15,3 +15,14 @@ define Profile/ANTMINER_S1/Description
        Package set optimized for the Bitmain Antminer S1.
 endef
 $(eval $(call Profile,ANTMINER_S1))
+
+define Profile/ANTMINER_S3
+       NAME:=Antminer S3
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINER_S1/Description
+       Package set optimized for the Bitmain Antminer S3.
+endef
+$(eval $(call Profile,ANTMINER_S3))