really fix tgz images
[openwrt.git] / target / linux / adm5120-2.6 / image / Makefile
index b9ae44e..829ddef 100644 (file)
@@ -121,10 +121,13 @@ endif
 endif
 endif
 endif
-ifeq ($(1),tgz)
+endef
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+  define Image/BuildKernel
        $(call Image/Build/RouterBoard)
+  endef
 endif
-endef
 
 define Image/Build/LZMAKernel
        $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \